MR600 v3 - Switzerland - 4G+ on and off

MR600 v3 - Switzerland - 4G+ on and off

MR600 v3 - Switzerland - 4G+ on and off
MR600 v3 - Switzerland - 4G+ on and off
2023-03-24 23:48:58 - last edited 2023-07-14 07:27:38
Model: Archer MR600  
Hardware Version: V3
Firmware Version: 1.0.0 0.9.1 v0001.0 Build 220307 Rel.60743n

Hi,

 

The 4G+ LED on my MR600 v3 regularly switches between on and off.

 

Network Mode is 4G Only. Selected Manual Bands are 3 and 20 (Sunrise - Switzerland). ISP settings shd be correct and current (ISP File 23021501).

 

DL and UL speed varies considerably (despite 100% signal strength), e.g. some 65 Mbps DL / 36Mbps UL initially (at 20:50h) and 20Mbps DL / 33 Mbps UL some hours later (00:34h), then 47Mbps DL and 32Mbps UL (00:43h). 

 

System Log also shows constant switching between LTE and LTE Plus, e.g. as follows:

 

3 2023-03-25 00:43:45 4G Information USER: Network type is LTE.
4 2023-03-25 00:43:11 4G Information USER: Network type is LTE PLUS.
5 2023-03-25 00:43:11 4G Information USER: Network type is LTE.
6 2023-03-25 00:43:10 4G Information USER: Network type is LTE PLUS.
7 2023-03-25 00:43:09 4G Information USER: Network type is LTE.
8 2023-03-25 00:43:08 4G Information USER: Network type is LTE PLUS.

 

Is there a way to get more stable DL/UL speeds / force 4G+?

 

Thanks,

Gerald

 

  5      
  5      
#1
Options
2 Accepted Solutions
Re:MR600 v3 - Switzerland - 4G+ on and off-Solution
2023-07-14 07:27:34 - last edited 2023-07-14 07:27:38

Hi All,

 

For carrier aggregation/4G+ issue, please refer to this post: Carrier Aggregation or 4G+ doesn’t work properly on LTE Advanced Router

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
Recommended Solution
  0  
  0  
#56
Options
Re:MR600 v3 - Switzerland - 4G+ on and off-Solution
2024-02-17 14:57:52 - last edited 2024-03-14 18:15:25

@Sunshine

I have now installed FW 1.1.0 0.9.1 v0001.0 Build 220727 Rel.74013n, but the problem of constantly (every 1-3 seconds) switching between 4G and 4G+ persists...

 

I have seen the private email from Maxwell of the TP-Link team re Qualcomm's response (also blaming the ISP/Carrier). However, I have still not received an answer to my question as to what specifically I shd ask the ISP/Carrier/Tower Operator to do (I have been asking for some guidance for some time). Would appreciate a response.

 

Thanks

Recommended Solution
  1  
  1  
#69
Options
71 Reply
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-26 22:42:01

PS: To clarify, my subscription is with FL1 (FL1 Free! - https://fl1.li/de/mobile-abos/free), which uses the Sunrise network in CH). I have tried using the FL1 APN profile, and tried turning NAT Boost off, tried different Band combinations (incl. ALL available bands, all 3 bands shown for Sunrise (1, 3, 20), but none of this makes a difference (occasionally 4G+ is shown in the web-interface, but most of the time it just shows Band 3 only). System Log shows that Network Type is constantly (every 1-2 seconds) changing between LTE and LTE PLUS. How can this be fixed?

  1  
  1  
#2
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 10:58:53

  @MobileRouter 

 

Hello, may I know if you have any other LTE Advanced Cat6 product available for comparison?

If so, please insert the same SIM card into another Cat6 product at the same location, then check if it would be on 4G+ stably, and if so, which band(s) it is using?

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#3
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 12:22:14

  @Sunshine 

 

Thanks for the prompt reply. Unfortunately I do not have another Cat6 mobile router (only my iPhone, though which I understand is probably a higher Cat class?).

 

Just in case, below is a screenshot of the available bands (FL1Test is my manually entered ISP/APN Profile, though situation is same with the Default Profile). Band 1 is selected automatically when I open the Band Search. I normally select then 3 and 20, as that combination provided the highest speed so far. However, on the Advanced Status page it shows Band 3 only (screenshot below). Any settings I shd change?

 

Thanks again 

 

 

  0  
  0  
#4
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 12:53:49

@Sunshine 

 

Also, below is an extract of the (apparently) available bands in Switzerland by Sunrise (source: https://en.wikipedia.org/wiki/List_of_LTE_networks_in_Europe -- assuming this list is up to date?):

 

  0  
  0  
#5
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 14:40:57 - last edited 2023-03-27 14:42:41

  @Sunshine 


Appears to be the same issue as with the "latest" MR600 v1 beta:
https://community.tp-link.com/en/home/forum/topic/579834?replyId=1129026 (and following comments)

  0  
  0  
#6
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 15:25:06

  @kernash 

 

Thanks for pointing this out, Kernash!

 

@ sunshine   

 

Based on the discussion referred to by Kernash, I have switched to Automatic Band selection. However, even though initially Advanced Status showed Bands 3, 1 were selected, subsequently it was Band 3 only, and System Log shows again a constant switching between LTE and LTE PLUS.

 

 

What can I do to fix this?

 

Thanks again

 

  1  
  1  
#7
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-27 15:35:36

@Sunshine 

 

Additional thought (of a layman only!): Is my understanding correct that the LTE modem is a separate PCI Card (attached to the Router)? And if so, is it possible to update the firmware of the modem card only? 

  0  
  0  
#8
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-28 07:17:40

  @MobileRouter 

 

Hi, when selecting two bands manually, it is normal that it might work on one band only, we are unable to control the carrier aggregation because it is decided by base station.

iPhone indeed supports much higher LTE category, but since no other device for comparison, you could still test the same SIM card on the iPhone and check which band(s) it is using at same location.

 

Regarding your last question, the MR600 includes LTE modem part and also router mode, but the available firmware usually includes both parts, users cannot choose to update one of the two parts only unless the released firmware only includes one part.

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#9
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-30 00:22:35

  @Sunshine 

 

Many thanks, I checked (with my main SIM card, same contract) as per https://www.tp-link.com/de/support/faq/3488/, and I can only see Band 3. Is there any other specific value I shd check?

 

But again, the System Log of the MR600 shows a constant switching between LTE and LTE Plus. And the Sunrise online network coverage map clearly shows 4G+ coverage at 100%.

 

And is it possible to simply "lock in" say B3 and B20 (both bands are used by Sunrise - see above) in the MR600?

 

Anything else I can do? If I speak to the Sunrise, what shd I tell / ask them? 

 

Thanks again

 

 

  0  
  0  
#10
Options
Re:MR600 v3 - Switzerland - 4G+ on and off
2023-03-31 12:48:13

@Sunshine 

 

Hi, I am now in Germany and took the MR600 with me. But the problem remains, 4G+ is on and off. I tried, inter alia, the following:

 

  1. Band Selection / CA set to Auto
  2. Reboot
  3. Advanced section showed CA 7+3
  4. Basic showed 4G+
  5. Speed test results: DL 109 Mbps and UL 12 Mbps 
  6. Back to Advanced section: shows 4G only with Band 7 only

 

Thus, this seems to be a HW/FW fault. Pls can you look into this and see to get this fixed ASAP. I am getting a bit frustrated now as I am already spending too much time simply on testing...

 

Also, I noted that there seems to be a lot of data streaming in the background, even though I hardly downloaded or streamed media etc. Does the router send info to TP-Link etc in the background? How can I block this?

 

Thanks again

 

 

 

  1  
  1  
#11
Options

Information

Helpful: 5

Views: 7789

Replies: 71

Related Articles