Archer AX72 (AX5400) VPN client issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer AX72 (AX5400) VPN client issue

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer AX72 (AX5400) VPN client issue
Archer AX72 (AX5400) VPN client issue
2023-05-19 20:17:04
Tags: #VPN
Model: Archer AX72  
Hardware Version: V1
Firmware Version: 1.1.2 Build 20220520 rel.75663(4555)

Hello,

 

I am trying to set up the VPN client on the router, with Mullvad.

 

I chose Android, as it is an option which gives me an unified .OVPN file.

 

I also tried the Windows option, which also gives a cert file, and I opened the .OVPN file, removed the cert part, and added the certificate tags, with the certificate content (certificate opened with Notepad++) between those certificate tags (at the end it basically looks the same as in the Android .OVPN file).

 

  

 

For the password Mullvad requires us to use our account number (which I made sure that is entered correctly, with no spaces), and the password to be one lowercase letter that they specifiy.

 

I Save the profile, I enable it, then it just gets stuck at "Connecting".

 

 

I am not sure what to do in this case. Can someone help me please?

  0      
  0      
#1
Options
7 Reply
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 20:49:38

  @Moderat 

 

Hi,

 

Chances are low that it will make a difference, but anyway, have you tried selecting "Linux" as the platform and use that configuration file with the AX72?

After all, the router is running a Linux operating system.

  0  
  0  
#2
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 21:01:12

  @woozle 

 

In the first place I get an additional file that there's no place to upload it in the router (update-resolv-conf), and there's a reference to it in the configuration file too, which of course it won't work.

 

 

 

I did the certificate thing again, as the certificate is not already included in the configuration file.

 

I also had to change the extension of the configuration file to ".OVPN" (the contents are basically the same as in an .OVPN file), otherwise the router would say that it's an invalid file type.

 

I also tried leaving the reference to the update-resolv-conf file, and also tried removing it, both times I got the same situation, stuck on Connecting.

  0  
  0  
#3
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 21:24:50

  @Moderat 

 

Since the Archer routers don't display a VPN connection log these sort of issues can be really hard to troubleshoot.

 

Maybe open the earlier ovpn file again in Notepad++ and remove the line "tun-ipv6". In don't think this option is useful when used with the Archer router.

 

  0  
  0  
#4
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 21:31:30

  @woozle 

 

Thanks,

 

As I'm still at my computer, I just tried what you suggested, but without success.

 

I also tried different combinations of these settings, again without success.

 

  0  
  0  
#5
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 22:07:12

  @Moderat 

 

By the way, have you already tested whether the connection to Mullvad VPN works at all using your certificate and credentials? Like via the OpenVPN client for Windows or Android?

  0  
  0  
#6
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-19 22:32:50

  @woozle 

 

Yes, I did.

 

  0  
  0  
#7
Options
Re:Archer AX72 (AX5400) VPN client issue
2023-05-22 03:49:35

@Moderat 

 

I agree with woozle that this may require further analysis with the engineers.

 

Can you please email the opvn file to support.forum@tp-link.com? Our engineer will contact you and try to figure it out.

  1  
  1  
#8
Options

Information

Helpful: 0

Views: 696

Replies: 7

Tags