VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers

VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers

VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers
VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers
2024-01-31 12:04:04 - last edited 2024-03-19 09:48:17

Before following this thread for troubleshooting, please do confirm the VPN problem type based on VPN usage scenarios described here.
For VPN Client related issue on TP-Link Routers, please refer to this thread: VPN Client on Wi-Fi Router Is Not Working

 

For VPN Server related issue on TP-Link Routers, please refer to the following cases to troubleshoot.

 

Case 1: Remote phone/laptop fails to connect VPN Server


Step 1: Check the router’s WAN IP address to see if it is a public IP address


 
1) If it is not a public IP address, it means there is another router or NAT in front of the TP-Link router, which blocks the VPN connection, you will need to open a service port on the front router or NAT device for the VPN connection, and then change the private WAN IP address to your real public IP address in the .ovpn file (for OpenVPN) and .conf file (for WireGuard VPN).
For example, for OpenVPN, you could refer to Step 3 in this guide: How do I troubleshoot if the OpenVPN is not connecting

 

Note: If there is no any other NAT product in front of the TP-Link router, it means your ISP assigns a CGNAT IP address or private IP address to you, which will cause VPN Server, port forwarding etc. don't work, you need to contact your ISP to see if they could offer you a public IP address.
 

2)    If it is a public IP address, please move to Step 2.
Note: If your WAN IP is public IP address but it is not static, please set up DDNS on the TP-Link router, or when the public IP changes, you will not be able to connect the VPN Server again without correcting the public IP address.

 

Step 2: For OpenVPN Server, please try to change the type from UDP to TCP

Step 3: Please make sure the VPN Client Software on your client device is installed and running under the ADMINISTRATOR Account.
Step 4: Ensure the same time settings on your VPN client device and the TP-Link router.
Step 5: Try disabling the firewall and security software on your VPN Client device

 
If the above steps still cannot solve the problem, please leave your comment or start a new thread and provide the following information for further troubleshooting:
1.    Model no., hardware and firmware version of your TP-Link router, model no. of the VPN client device
2.    Your specific network topology and what you want to achieve via VPN
3.    The current problem phenomenon
4.    The .ovpn file for OpenVPN or .conf file for WireGuard VPN, and screenshots of all VPN Settings
5.    Log file of the VPN client if you have

 

 

Case 2: Remote devices connect the VPN Server successfully but cannot access internet any more
 

For this issue, please leave your comment or start a new thread and provide the following information:
1.    Model no., hardware and firmware version of your TP-Link router, model no. of the VPN client device
2.    The .ovpn file for OpenVPN or .conf file for WireGuard VPN, and screenshots of all VPN Settings
3.    The current problem phenomenon

 

Case 3: Remote devices connect the VPN Server successfully but cannot access local resource of the VPN Server
 

Please refer to this guide for detailed troubleshooting: Why can’t I access or discover certain devices over VPN

 

Related Article:

Introduction and Configuration Guide of VPN Function on TP-Link Wireless Routers 

Integration of VPN Services with Renowned Third-party VPN Providers NordVPN and SurfShark

  2      
  2      
#1
Options
2 Reply
Re:VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers
2024-02-27 01:51:44

  @Sunshine 

if I use OPENVPN then I can access LAN connected device and internet

if I use Wireguard then I can't connect to LAN devices but able to access internet.

 

I have created a threat.

https://community.tp-link.com/en/home/forum/topic/657102

  0  
  0  
#5
Options
Re:VPN Server Is Not Working Properly on TP-Link Wi-Fi Routers
2024-02-27 08:24:47

  @RonDeChaka 

 

Thanks for the feedback, I just replied your another thread, we could follow up the issue there, please have a check.

  0  
  0  
#6
Options

Information

Helpful: 2

Views: 1491

Replies: 2