ADSL connects, but no internet on devices

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ADSL connects, but no internet on devices
ADSL connects, but no internet on devices
2015-03-12 15:16:05
Region : Argentina

Model : TD-W8968

Hardware Version : V3

Firmware Version :

ISP :


Hi there (Issue is related to Archer D7, but it's not on the dropdown for model numbers)

I have a new line with ADSL and bought this router brand new.
I started up and inserted my ADSL username and password, and the ADSL seems to connect.

I have a solid ADSL and internet light on the modem. My ISP can also confirm that I am connected to them, and they can see the account authenticates and works fine.

Unfortunately though, no devices I connect to the router can connect to the internet. I tried connecting my laptop via wired and wifi connection, I also tried connecting my android tablet via wifi. I am able to connect to the router successfully from all the devices, but I just have no internet access.

We also tried bridge and then pppoe dishing from the machine, that also failed to connect.

My ISP believes that this is a hardware issue. Can there be any other problems?

Thanks.
0
0
#1
Options
1 Reply
Re:ADSL connects, but no internet on devices
2015-03-13 17:23:39
Maybe it is a DNS issue. On web interface of W8968, go to Network---LAN Settings and change primary DNS to 8.8.8.8, Save it.
When you open any webpage, what's the error message?
0
0
#2
Options