KP105 Local Only and not playing nicely with Google Home

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

KP105 Local Only and not playing nicely with Google Home

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
KP105 Local Only and not playing nicely with Google Home
KP105 Local Only and not playing nicely with Google Home
2020-11-30 10:22:00
Model: Kasa  
Hardware Version: V1
Firmware Version: 1.0.5

I have two new KP105's with latest firmware and am struggling to get them to work properly/reliably with Google home (or indeed even with the Kasa app)

 

They make it through the setup properly in the app and connect to our wifi network fine with a good signal

After a very short time both devices are showing as "local only" in the Kasa app and not providing state information to Google Home

Strangely though, I can still turn them off and on from the Google home app and via voice from a Google home device using voice commands so the KP105's are at least partially connecting to the internet

 

The Kasa app works locally on wifi but not over 4G,

`

I have un-linked and relinked kasa to google with no improvement

I have removed and re-configured the switches in the Kasa app.. also no improvement

 

I have a sonoff E26 running with ewelink software that has been 100% reliable on the same network so it is unlikely to be local network issues. (using Mikrotik routers and access points)

 

I was about to buy several more of these but am now holding off .. and will return the two i have if it's not working.

My wifi and broadband are reliable and signal strength is good,

 

NB:  I cannot select the KP105 in the model pulldown menu in this forum. Could TP-link admins please fix that?

  0      
  0      
#1
Options
9 Reply
Re:KP105 Local Only and not playing nicely with Google Home
2020-11-30 21:09:01

Just to add to this, it appears that the devices occasionally show up while on 4G... But only intermittently. 

 

If anyone from tplink support checks these forums, I have a pcap trace of the traffic from boot to"local only* including turning off and on in the kasa app and via Google home. Hopefully that should provide sufficient material to work out what is going on.

 

 

 

 

 

 

  0  
  0  
#2
Options
Re:KP105 Local Only and not playing nicely with Google Home
2020-12-03 03:00:38

@BigCanoe 

Hi, sorry for the delay.

We would like to follow up on your case by email later.

And could you please help me check the following information:

1. When the KP105 showed up as local only, could you still control it via Google home app and via voice from a Google home device?

2. May I know the model number of your home router?

3. Both of them have the same issue, right?

4. Did this issue start since you bought the plugs?

 

Thank you very much for your understanding and support.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#3
Options
Re:KP105 Local Only and not playing nicely with Google Home
2020-12-03 10:45:38

@TP-Link 

 

thanks for the response

 

1) yes, when it shows up as local only I am able to turn it off and on using the google home app or voice via our google home mini if i am on the same wifi network (I can see in the traffic that the KP105's are communicating with the home mini on port 9999). When i am on 4G however, the google home app shows the KP105's as offline most of the time and i cannot properly control them but the do occasionally seem to work.

I have a packet capture from when the google home app definitely indicates the devices as offline but i managed to make one of them work. The device is talking to an AWS host at 34.197.7.30. (use1-api.tplinkra.com)

 

2) the router is a Mikrotik RB750GR2 and the access point is a Mikrotik RB951G-2HnD (this is prosumer grade equipment and the main router is set as the AP controller... i have very good visibility and control over what is going on on the network including ability to capture packets to/from the KP105's). Firmware in all cases is the latest 6.47.8.. I have three access points in the house and in each case the KP105's are in the same room as the AP's the distance to the AP is about 4m. 

 

3) yes, both have the same issue. I have no other issues on the network and the speed, ping times etc are  stable. There are multiple other devices working well on the network. Broadband speed is 50/10 megabit

 

4) yes, this issue has been there since i bought the plugs (i bought them last week)

 

 

 

 

 

 

  0  
  0  
#4
Options
Re:KP105 Local Only and not playing nicely with Google Home
2020-12-07 16:44:23 - last edited 2020-12-08 22:27:36

@TP-link

 

Anything?? 

I'd really like these to work properly

 (or know that they won't do I can return them)

 

Thanks

  0  
  0  
#5
Options
Re:KP105 Local Only and not playing nicely with Google Home
2020-12-09 03:22:02

@BigCanoe 

Hi, thank you very much for your kind reply.

We would like to follow up on your case by email and forward to our senior engineers for further help.

Please have a check of your email box later.

Thank you very much.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#6
Options
Re:KP105 Local Only and not playing nicely with Google Home
2020-12-13 17:43:53

I'm just leaving a note in case others find this thread and have similar issues

 

It appears that the KP105 running firmware 1.0.5 has a bug in handling DNS and possibly DHCP

 

If your router is not on x.x.x.1 the KP105 will incorrectly send DNS packets to x.x.x.1 anyway which do not get a reply so the KP105 does not know how to reach its cloud servers  and goes to local only mode (despite having previously received a correct DNS response with the right addresses)

This was only found through packet tracing and there being a device (not a router)  on x.x.x.1 on my network. In my case the Mikrotik has build in packet trace and capture which made it possible to find. Special thanks to some gurus on mikrotiks forums for finding the issue.

 

It's been reported to tp-link support.

 

Moving the router to x.x.x.1 appears to have made it work properly but the bug needs fixing.

  0  
  0  
#7
Options
Re:KP105 Local Only and not playing nicely with Google Home
2022-02-14 17:27:58

To fix this on my end, I opened the device within the Kasa app, clicked on the Cog (top right) and there was a button at the top (it disappears once you tap it, so I can't remember what it says).

 

This stops the device being local only, and will now appear in Google Home.

  0  
  0  
#8
Options
Re:KP105 Local Only and not playing nicely with Google Home
2022-02-15 17:40:27

  @BigCanoe all the kasa devices will blat your lan with malformed dns queries. it's been like this for years - they don't care. they've polled our lan, hashed whatever they can glean about where you shop for mac addresses and left you with a mess of devices in the wrong multicast groups. you will at some point trip and firewall yourself hehehe

  0  
  0  
#9
Options
Re:KP105 Local Only and not playing nicely with Google Home
2022-02-16 15:40:23

  @Ricky666 

thanks... I sort of guessed as much but have not bothered to chase down packet traces etc.

its working fine since I moved the router to x.x.x.1 

I'll hve to look at my pi-hole and see if dns queries are going there or not

 

my own solution is going to be to vlan off all IoT devices in the near term anyway (and only give the well behaved ones internet access perhaps)

Mikrotik does a pretty good job of such things afaik... just another SSID for IoT (going to add a camera which is the impetus for tighet security

 

there have been two firmware updates since i posted this but I have no idea if anything has been fixed.

  0  
  0  
#10
Options

Information

Helpful: 0

Views: 1042

Replies: 9

Related Articles