PSA: Stuck relay / dead Tapo plug? You're in the right place

PSA: Stuck relay / dead Tapo plug? You're in the right place

PSA: Stuck relay / dead Tapo plug? You're in the right place
PSA: Stuck relay / dead Tapo plug? You're in the right place
2023-11-10 14:03:58
Model: Tapo P100   Tapo P110  
Hardware Version:
Firmware Version:

Hi all

 

I first found this forum looking for advice on how to fix a stuck relay in a Tapo P100, which I'm sure many here will have experienced from previous threads. I myself have had about 20 of these units. I had two replaced by Tapo. I had another 4 which had also started showing this issue.

 

I was hoping to find instructions to disassemble the device and replace the stuck component. I didn't find any. In fact, the bulk of advice suggested it was time for the bin for these units.

 

If someone else has already mentioned this then apologies - but in case they haven't, I have found a resolution for this issue and now 100% of my Tapo plugs are working for now.

 

Difficulty: Stone age

Time to fix: 15 seconds

Tools required: Kitchen counter

Steps:
1) Bang your Tapo plug very hard on the kitchen surface on every side except the side with the plug pins.

2) Test.

 

Hope this helps someone - if so, you're welcome!

  2      
  2      
#1
Options
1 Reply
Re:PSA: Stuck relay / dead Tapo plug? You're in the right place
2023-11-10 14:13:53

PS Someone mentioned on the original thread I found when I reported this that the issue will likely recur. I do not doubt this. But since the issue will likely occur on all of the Tapo plugs since the relays are obviously rubbi5h, this is at least a temporary solution... and mine are all still working.

  0  
  0  
#2
Options

Information

Helpful: 2

Views: 267

Replies: 1