Archer C1900 Rejects Connection after a day

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C1900 Rejects Connection after a day
Archer C1900 Rejects Connection after a day
2018-03-29 02:22:24
Model :

Hardware Version :

Firmware Version :

ISP :

I have an Archer C1900 v1. It is set up as a Wifi Access point, with DHCP turned off.
I have both the 2.4 and 5G turned on, each with a Different SSID.
Both Wifi bands Have been set to use the Same Password.

recently, I loose the connection from my device, and all attempts to reconnect fail. Bad Password.
If I power off, and Power on the Wifi router, All connections work again...
then a day later, the same thing...

I've done the 30/30/30 Hard reset. and re-configured it..

But it still is the same...

It is using firmware 20151009-rel61423
Which is the Latest available I see on the support site.

Is it an Over heat Issue?
a Firmware Issue... ?

S/N 215C793000219 US/1.0
0
0
#1
Options
3 Reply
Re:Archer C1900 Rejects Connection after a day
2018-03-29 09:48:24
how many clients are connected to C1900? it could be over-load? try to disconnect several devices and keep few devices online.
0
0
#2
Options
Re:Archer C1900 Rejects Connection after a day
2018-03-30 01:18:51

vieldcs wrote

how many clients are connected to C1900? it could be over-load? try to disconnect several devices and keep few devices online.


usually only 1 or 2 devices...
0
0
#3
Options
Re:Archer C1900 Rejects Connection after a day
2018-03-30 10:07:02
what kind of devices? google ? it could be either compatibility issue or hardware issue.
you would better contact tp-link support for further help.
0
0
#4
Options