Archer C7 V2 slow WLAN/LAN connection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C7 V2 slow WLAN/LAN connection
Archer C7 V2 slow WLAN/LAN connection
2018-05-08 00:02:26
Model :

Hardware Version :

Firmware Version :

ISP :

Model : Archer C7

Hardware Version : V2

Firmware Version : 3.15.3 Build 180114 Rel.39265n

ISP : Xfinity/Comcast (400Mbps Internet Plan)

Cable: CAT 5e

Cable Modem: Arris SB6190 (Max Download Speed: 1.4Gbps )

Test method: xfinity speedtest + speedtest.net

I am not able to pull full 400Mbps speed out of my Archer C7 AC1750's gigabit Ethernet port using wire connection:
PC <-> Modem = 400~450Mbps
But if I put C7 in between the max I can get is 270~280Mbps:
PC <-> C7 <-> Modem =
270~280Mbps
Both cables are CAT5e and are all able to reach 400Mbps+ if hooked PC<-> Modem directly.

Can somebody help me debug what's going on? Is C7 such a bad router for wire transmission?!?!
  0      
  0      
#1
Options
8 Reply
Re:Archer C7 V2 slow WLAN/LAN connection
2018-05-11 14:49:12
Try to check whether the hardware NAT is enabled on the router.
  0  
  0  
#2
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2018-05-11 15:09:21
You may check your lan cable first, some old cable does no support giga speed
  0  
  0  
#3
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2018-05-12 01:00:21
I couldn't find any NAT or QoS options in the setting.
  0  
  0  
#4
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2018-05-12 01:00:54

Enson Loo wrote

Try to check whether the hardware NAT is enabled on the router.


I couldn't find any NAT or QoS options in the setting.
  0  
  0  
#5
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2018-05-12 01:02:21

ic3b34r wrote

You may check your lan cable first, some old cable does no support giga speed


Cables meet CAT5e and able to deliver 400mbps without router in between. I've tested the cables.
  0  
  0  
#6
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2020-01-07 22:55:17

@lbyinchina 

 

Bumping this old thread back up.  I'm having almost the EXACT same problem with my Archer C7 V2 router as the OP except my service provider is Spectrum.  Here are my particulars:

 

 

Model : Archer C7


Hardware Version : V2

Firmware Version : 3.14.3 Build 151014 Rel.49676n

ISP : Spectrum (400Mbps Internet Plan)

Cable: CAT 6 throughout

Cable Modem: Arris SB6190 (Max Download Speed: 1.4Gbps )

Test method: Spectrum Interent Speed Test website

 

When I plug my computer straight into the SB6190 cable modem (i.e. bypass the Archer C7 router), I am consistently getting more than 400Mbps download speed as determined by the Spectrum Internet Speed Test website.  Once I plug the SB6190 modem back into the Archer C7 router WAN port and my computer back into a gigabit LAN port on the Archer C7 router (CAT 6 cabling used throughout all connections), I get 400Mbps for about 10 minutes and then it drops to a consistent 250Mbps. 

 

Based on this testing it appears the drop is occurring in the Archer C7 router and not the Arris SB6190 modem.  So the good news is that the SB6190 appears to be working like it should with all the cable connections coming to the house being "good".

 

I've done some testing on the Archer C7 router throughout the day and sure enough - every time I unplug/plug the SB6190 back into the Archer C7 WAN port, I get about 10 minutes of 400Mbps speed followed by a drop to a consistent speed of 250Mbps.  All speed checks are being done via the Spectrum Interent Speed Test website.  

 

I don't have anything else plugged into/running through the Archer C7 router that could cause this kind of speed drop so does anyone have any ideas as to what is going on in the Archer C7 to cause this speed reduction?

  0  
  0  
#7
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2020-03-26 11:14:52

@Tabbyplague I have the same problem with a C7 V3, stock firmware, as there was no firmware update for V3, Spectrum 450 down, router settles in at 310-320 about 10 minutes after a router reboot, all LAN ports the same.

  0  
  0  
#8
Options
Re:Archer C7 V2 slow WLAN/LAN connection
2020-03-26 12:05:35 - last edited 2020-03-26 12:07:44

@RobertJ 

 

I could never get the problem resolved with my Archer C7 - it would never give me my full 400Mbps speed for more than a few minutes.  So I ditched the Archer and replaced it with an ASUS RT-AC86U.  Boy am I glad that I did - everything in my network is faster with a stable WAN connection that never drops below my max cable Interent connection speed.  I've always liked TP-Link products but was sorely disappointed in the performance of the Archer C7.

  0  
  0  
#9
Options