Archer C7 Will Not Connect Via LAN, Wi-Fi Works

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C7 Will Not Connect Via LAN, Wi-Fi Works

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C7 Will Not Connect Via LAN, Wi-Fi Works
Archer C7 Will Not Connect Via LAN, Wi-Fi Works
2018-08-02 00:20:20
Model :

Hardware Version :

Firmware Version :

ISP :

Good Morning, I recently got an Archer C7 have been having problems setting up the wired connections. I have no issues with wi-fi, but none of the devices connected via LAN will connect to the internet.

3 LAN lights are lit up on the front of the router, but only 2 wired clients are showing in my TP-Link admin site. Both of those devices are NOT connected to the internet.

I have 3 devices connected to via LAN (PC, TimeCapsule, and ATT M-Cell), but the TP-Link admin site will not recognize my PC, even though the light is lit on the router. On my PC, I have looked at the network connections but it will not connect. It just says "unknown network".

I have several other devices connected via wi-fi without any issues, and I am even able to connect my PC via wi-fi if I turn on the wireless adapter.

Other specifics:

Xfinity internet, netgear modem, working cables, have done several restarts and wipes of the modem and router. Tried different cables, ports, etc. There seems to be something that is just not allowing LAN to connect to the internet.
  0      
  0      
#1
Options
1 Reply
Re:Archer C7 Will Not Connect Via LAN, Wi-Fi Works
2018-08-02 16:12:58
how about reset the router? this is very weird..
  1  
  1  
#2
Options

Information

Helpful: 0

Views: 563

Replies: 1

Related Articles