HS210 status is wrong in app

HS210 status is wrong in app
HS210 status is wrong in app
2018-12-26 19:24:18

Just installed a TP-Link HS210 in a circuit that had two three-way switches and a four-way switch.  I made sure to install the HS210 to replace the first three-way which was fed with power from the circuit breaker.  Electrically everything works fine, I can turn the lights on and off from any switch and can turn them on from a given switch and off from another switch fine with no problem.  The issue is that from the Kasa app and from the Alexa app I cannot tell the status of the lights.  Both apps show the status of the light as off even though it is on.  When I click the icon to turn on it turns green for a second and the light physically turns on but shortly afterwards the icon goes grey even though the light is on.  In Alexa when I turn it on it will go on and the icon goes green but then the icon in a few seconds shows off - it will over 20 seconds or so switch a few times between on and off and then will stay at off even though the lights are on.

0
0
#1
Options
5 Replies
Re:HS210 status is wrong in app
2018-12-26 19:48:03
Called support and they had me delete the Kasa app on my iPhone and reinstall it. Once I did all is fine in both the app AND in the Alexa app. Very strange, but it fixed things.
0
0
#2
Options
Re:HS210 status is wrong in app
2019-12-06 20:45:51

Having the exact same problem. Reinstalled the app and still nothing. 

0
0
#3
Options
Re:HS210 status is wrong in app
2019-12-11 20:37:03

@OuterLimit I have the same problem.  In my case there is a small leakage current on the traveler that keeps the small LED buld that is being controlled very dimly lit.  It seems to be enough current however, for the switch to think the light is ON.  (I've deduced the only way for the HS-210 to know if the light is off or on is to measure the current in its two travelers since it can't know the state of the other 3-way switch.  Current flowing = ON, No current flowing = OFF).   Looking for a fix.  None of my other HS-210's seem to have that problem with LED lights.

0
0
#4
Options
Re:HS210 status is wrong in app
2019-12-31 21:14:41

@OuterLimit I also had the same problem in the original post.  I had a 3-way / 4-way / 3-way circuit.  I replaced the 3-way switch on the line side, but it would always think the light was off.  I tried swapping out the smart switch, but the other one behaved the same.  Once I replaced the second 3-way switch with the other smart switch, it was properly detecting the status of the light.  Even flipping the dummy 4-way switch will toggle the status correctly.  I was under the impression that you only needed one smart switch, but I was only able to get it to work with both.

 

0
0
#5
Options
Re:HS210 status is wrong in app
2019-12-31 21:50:33

@keifer 

 

Appreciate the reply and ended up with the same solution. Once I added the second switch all was good. Only thing I could think was a dumb motion sensor sharing the common line leaking power. 
 

Few days later did another room with a four way (no motion sensor) and everything worked great with a single 210.

0
0
#6
Options