Local only

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
1111213...16
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Re:Local only
2021-12-24 01:24:30 - last edited 2021-12-24 01:36:00

@JCPhoenix 

Hello 

If kasa devices become 'local only' after power outage and restoration , you could try :

 

  • confirm smart devices have strong signal at its location:

Kasa app-> Device Settings-> tap name of the device ->signal strength ( tap on the Wi-Fi icon to see the value of the dBm/RSSI)

(-40- 70dBm is good to average, less than -70dBm is relatively poor : relocate device or router to get stronger signal)

  • If you have a mesh system or router + extender in the house,   try to force kasa plug to the node which has the strongest signal for kasa device
  • Try to turn off Wireless advanced settings like Wi-Fi roaming/ Band steering/ Wi-Fi or Channel optimization and see if that helps
  • Confirm kasa app version & device firmware are both up to date

 

If the above does not work, can you help provide some information here: 

  1. model of router
  2.   detailed network map: e.g. ISP XX--Router Model XX  <Wireless> Kasa devices 
  3.  does all the device become 'local only' or only certain of them
  4. please let us know the Mac address of device having the issue' by pm

Thank you 

 

1
1
#116
Options
Re:Re:Re:Local only
2021-12-30 01:47:41

@Tplink 

you all need to fix this issue asap I have over 15 plugs and not working anymore because of your update fix this issue or I'm going to be returning all this Kasa and tplink stuff

0
0
#117
Options
Re:Re:Re:Local only
2021-12-30 19:44:21

@Rorg75 

 

This isn't a regular issue we can just issue and apply a fix to.  It aslo not somthing that occurs regularly. Also it is possible that it is due to local equipment and or configurations, such as the router being used and if any filters or ACLs are applied.  If you have 15 plugs and they are all having this same concern, especially if they are all different models that would point even more so to a local equipment issue.  We would in your case highly recommend you contact our live support as you will need to troubleshoot this in a more direct and broadstream manner.  Live support does vary by region so please go to TP-Link.com click on Support and then Contact Technical Support.   

 

We could still do this through the community but we would need a lot of network infromation about your setup, configuration, equipment, etc. and a lot of customers are not comfortable sharing that much publicly.   

0
0
#118
Options
Re:Re:Re:Local only
2021-12-30 19:55:17

@Rorg75 

 

The easiest and fastest fix for this is to use the App to get the MAC addresses, then on your router, find that address and tell your router to reserve the IP for that device, then reboot the device.  I have about the same number of plugs as you have and did that 2 years ago.  They've worked ever since.  

 

I recently upgaded (due to some other things I do with my network) from a consumer grade router to a commercial grade router (Ubiquiti UDM Pro from Synology router).  When I did, I decided not to assign static IP's or reserve IPs on the router for the TP-Link devices to test this all out.  I've been runing this way now for 3 months and have not had any sign of this issue.  As such, I've resigned to the fact that there was something wtih the way my Synology router was handling the traffic (I'm guessing having to do with NAT) that caused the issue.  

 

That said, since I have other devices in my home (my home is nearly fully automated) that also rely on some cloud connection at times and none of them have this issue, makes me think that the root of the issue is still the way these devices choose to "phone home". Perhpas using a different protocol (tcp vs udp, etc) or a different port (maybe they are using a non-standard port) would resolve this issue for some of the routers out there.

 

In any case, although it took me about 2 hours initially to reserve IPs for all the TP-Link devices, it resolved the issue and worked flawlessly for 2 years after donig so.  

 

Cheers and good luck....

0
0
#119
Options
Re:Re:Re:Local only
2022-01-05 09:29:22

@Carl 

 

Still having this issue, any update?

0
0
#120
Options
Re:Re:Re:Local only
2022-01-05 17:58:51

@darkrock76 

 

Given the amout of Kasa Devices deployed its not a widespread issue.  So there is no generized fix we can apply.  Thus we have to handle each instance individually.  You can share the details of your concern here or work directly with support at Kasa.Support@tp-link.com.

0
0
#121
Options
Re:Re:Re:Local only
2022-01-06 16:17:58

@Carl 

I am having the same issue here in Ohio. I have several plugs and 2 switches. Half of the devices are not working. The funny thing is that plug in the same room as the router is not working, showing Local Only, but the plug in the other rooms away from the router are working just fine.  

 

This is really discouraging since I'm only having issues with Kasa devices showing Local only.  I have smart plugs from other companies and they all are working fine. 

 

One more thing, I use home assisatant and all the devices are showing up good in there. And I'm able to turn on/ off using Home Assistant application. But the devices showing local only don't work with Google Home or Alexa. 

 

I checked my router and all the devices are showing as connected in there, so the plugs have an IP address and are showing up on the network. Why they're still showing up as Local only is a mystery. 

0
0
#122
Options
Re:Re:Re:Local only
2022-01-06 16:44:26

@mail4asim 

 

The problem is the plugs showing local only can't reach the internet.  There is a problem between them and your router.  It usually has to do with how the router handles DNS traffic for the Internet and NAT.  I had the same issue with mine at first.  However, as several of my earlier posts show, I took the time to hard reset each switch, then give them each a static IP (you can do this in the app or just go to your router and use it's reserve IP function).  Then everything started working and I've not had issues since.

 

That said, in the meantime, I've decided having devices in my home network that phone home and call cloud services are inately insecure.  Therefore, I've moved to Home Assistant like you and run everything through my own server with a SSL cert I purchased.  

 

As an additional note, I was using residential class routers (Synology) when I had the issue.  I changed to a more robust option (Uniquiti UDM Pro) and ran the devices without static IPs for a while and not in a VLAN with Internet restricted, just to see if the engineers here were BS'ing us.  For the month that I ran it like that none of the plugs went to local only.  So, I believe it deals with how many of the residential routers handle traffic.

 

Granted, it seems to me that if other companies' devices don't have this issue, then TP-Link should be able to change how the devices reach their cloud servers to get around this issue, but until they decide to do this we do have a way to resolve the issue.

1
1
#123
Options
Re:Re:Re:Local only
2022-02-08 23:03:49

@Carl , any update? A bunch of my smart outlets are doing this aND all firmware is updated.

0
0
#124
Options
Re:Re:Re:Local only
2022-02-09 01:40:40

@Rick423 Have you reserved IP's for them using their MAC addresses on your router?  It appears that all who've done this have had no more issues.

 

Look earlier in the posts and you'll see a detailed step by step process I did to resolve it.  It took time, but in the nearly 2 years since, I've had zero issues.  I've even changed routers twice.  Each time I reserved IPs for the MACs and had no issues.

 

I will say as my last post says, I do think it's an issue between the way TP Link devices phone home and how the current batch of residential class routers handle NAT traffic.  I recently moved to a "Prosumer" router (not as high end as a professional class router, but higher than a consumer grade) that runs on a Linux based OS and have not assigned IPs to the MACs for any of my TP link devices and haven't had any issues.  Since this device (a Ubiquiti UDM Pro) doesn't take the short cuts that many consumer grade routers do in sacrificing some higher end functions for ease of use, I suspect it is something in this "ease of use" functionality that consumer grade routers have issues with TP Link.

 

TP Link moderators - this does not give you license to excuse the problem.  Given that I also have many other smart plugs and smart IoT devices on my network and TP Link are the only ones that EVERY had this issue, I suspect there is a way for you to get around this limitation of consumer grade products.  Given that your target market are consumers and not business or Pro's, this should be a priority for you.

 

Ok, soap box unmounted.

 

Hope you can get it fixed using these steps @Rick423.  I also suggest you look into Home Assistant.  It's a small program that can run on any machine and hosts an internal website that will integrate with nearly any IoT device out there without it's need to go outside of your local network.  Then you can use it to control everything as it can be used in an app on your phone (Android or iPhone) and other OSs.  works great and integrates all your IoT devices control into one app.  I use it extensively now and it runs all my Home Automation.

 

I've even setup some automations triggered by events..like when I come home from work, it automatically turns on certain lights, the tv to Netflix (and if I want it, music on another device), along with setting the Thermostat to the temp I like.  All this based on when I open my garage door between certain times and when my phone's GPS is within a certain distance of my home.

 

It takes some time to get the hang of setting these up, but once you've understood the process they are simple.

 

Cheers!

 

Live Long, Learn Lots, Love Well....

1
1
#125
Options