WD MyCloud not accessable with Deco M4R

WD MyCloud not accessable with Deco M4R
WD MyCloud not accessable with Deco M4R
2019-12-19 08:37:43
Model: Deco M4
Hardware Version:
Firmware Version: 1.1.0 Build 20190620 Rel. 45372

I purchased the TP-Link Deco M4 from Amazon, and ditched my old Apple AirPort Extreme router. Since doing so, I cannot access my WD My Cloud NAS. I had no issues with the Apple router being able to connect to MyCloud. I didn't change any IP adresses or anything with the Deco. I am able to get into the MyCloud from logging in online, but not outside of my house wifi. If I try to access outside my home wifi, it says that it's unavailable and it can't find the device. I literally didn't change a single setting or address IP when setting up the Deco. I've even messed around with adding a reservation through the Deco M4 app for the MyCloud IP adress and still nothing. Any suggestions to have access to MyCloud outside my home wifi?? It's such a bummer because I'm hoping that it isn't something within the Deco software preventing the MyCloud from passing through.

0
0
#1
Options
5 Reply
Re:WD MyCloud not accessable with Deco M4R
2019-12-20 18:51:09

@Jfringer 

 

Hi  you actually need to enable port forwarding for this function.

 

we found this on WD's community:  https://community.wd.com/t/port-forwarding/92403.  one user wrote:

 

Etupes

Apr '14

Yes, this is normal. On your local network, the NAS keeps the ports 80 and 443 to work. When a connection comes from the outside though, on the ports 9080 or 9443 of your router WAN side, your router will forward the traffic to your NAS on the corresponding ports.

Make sure you have set up the port forwarding in the router, and that you have specified in the NAS which ports your have setup.

 

 

This should help but if not let us know and we can look further into it.

0
0
#2
Options
Re:WD MyCloud not accessable with Deco M4R
2019-12-21 12:49:59

@Carl thank you! I'll try that and let you know how it works! 

0
0
#3
Options
Re:WD MyCloud not accessable with Deco M4R
2020-03-02 10:32:12

@Carl I tried doing that you instructed, but had no luck. It's still saying "connecting... trying to establish a remote access connection.". Am I doing something wrong here? In the Deco M4 app, I added two port forwarding HTTP. (1) for internal port 80, external port 9080. (2) for internal port 443, external port 9443. Then I set my WD Cloud to port 1: 9080, and port 2: 9443. Still no luck and cannot connect outside my home network :( 

0
0
#5
Options
Re:WD MyCloud not accessable with Deco M4R
2020-10-11 11:55:29 - last edited 2020-10-11 11:57:25

I was facing the same problem with my Deco M9.

Followed the instruction and setup port forwarding for 9080 & 9443.

Since then when connecting from remotely (4G) it shows my folder structure but i cannot access any files when trying to open them.

0
0
#6
Options
Re:WD MyCloud not accessable with Deco M4R
2021-02-04 16:34:56

@Jfringer I got this working and this is how i did it on my Deco vs WD Cloud

 

In WD Cloud set up HTTP and HTTPS

 

HTTP

External Port: 9080

Internal Port: 80

TLS

 

HTTPS

External Port: 9443
Internal Port: 443

TLS

 

within your Deco go to port forwarding and do the following

 

Name: WDCloud HTTP

External Port: 9080

Select the WD Cloud device from your IP list

Internal Port: 80

Type: TLS (it's set as ALL as default, change this to TLS)

 

Name: WDCloud HTTPS

External Port: 9443

Select the WD Cloud device from your IP list

Internal Port: 443

Type: TLS (it's set as ALL as default, change this to TLS)

 

Now the next point is vital, go to your WD CLOUD and restart the device. Once restarted you can now access the device outside of your home. To test I stuck my phone off the WIFI to use my mobile data and could now successfully connect where as my tests before I could not until I restarted the WD Cloud device.

 

I hope this helps who ever may be struggling

1
1
#7
Options