TP-Link Archer C4000 no longer works after firmware upgrade and reset

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TP-Link Archer C4000 no longer works after firmware upgrade and reset

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP-Link Archer C4000 no longer works after firmware upgrade and reset
TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-04-27 16:31:41
Model: Archer C4000  
Hardware Version: V2
Firmware Version: Archer C4000(US)_V2_190827

Yesterday 4/26/2020 I tried to access my Archer c4000 to do a firmware upgrade, and mistakenly tried using the account password instead of the router password, and of course couldn't get in, so I ended up having to do a reset of the router.  I set it up according to the setting I saved in a password protected Word doc created when I first set it up back last August when I bought it.  The firmware upgraded successfully, but suddenly I had no connectivity.  I plugged my computer directly into the modem and was able to verify that the modem was working just fine, but when I added the router back I had no connectivity wired or wireless, so I called TP-Link tech support, and the tech who I reached basically led me in circles three or four times, and since I'm an IT guy and familiar with good and bad support finally hung on on them, the support was THAT bad!  Now I have a router that won't work and I find that TP-Link phone support is down today for scheduled maintenance.  I live in a cellular dead spot, so I have to use a cell tower to even get cell service in my house, which means that my wife and currently can't use our cell phones, our iPad or laptop, or our wired computer connection.  I'm currently 30 minutes away from home sending this message at work where I do have connectivity, which is the only way that I can send this message.  Can anyone please help me with this issue?

Ron Durham
  0      
  0      
#1
Options
7 Reply
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-04-28 16:22:22

@bluerondo 

 

If your modem checks out, connect the router back to the modem, leave the router on and reboot just the modem. After a couple of minutes, see if the internet light on the router if it is the same color as the others.

 

If the internet light stays amber, log into the router, and see what the internet IP address if has. If the IP address is all 0s then the modem is still not recognizing the router. Since your computer worked, try and have the router clone the MAC of your computer to see if it then gets an IP address. If the IP is something like 192.168.100.1 then the modem is not provisioning correct which the ISP and reset.

 

If you do have a public IP address, configure the WAN DNS servers to be 8.8.8.8 and 8.8.4.4.

  0  
  0  
#2
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-10 06:05:12

@bluerondo 

 

Your experience is not unique. I have also experienced the same issue. Now almost a year after the update came out.

The admin page becomes almost inaccessible, often resetting back to logon page.

I can reboot the device (back power switch) after which it will function, for about 10 minutes.

Then it's back to spotty functionality. I am frankly amazed that they're continuing to provide faulty firmware.

(It's a shame what the entire IT world has come to.)

I'm going to try reverting to older firmware and will post here if there's any relief.

bluerondo wrote

Yesterday 4/26/2020 I tried to access my Archer c4000 to do a firmware upgrade, and mistakenly tried using the account password instead of the router password, and of course couldn't get in, so I ended up having to do a reset of the router.  I set it up according to the setting I saved in a password protected Word doc created when I first set it up back last August when I bought it.  The firmware upgraded successfully, but suddenly I had no connectivity.  I plugged my computer directly into the modem and was able to verify that the modem was working just fine, but when I added the router back I had no connectivity wired or wireless,  Can anyone please help me with this issue?

 

  0  
  0  
#3
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-10 06:25:59
No go; cannot downgrade. I could however re-apply the current version. "maybe" there was a problem the first time around. We'll see what happens in another 15 minutes (fingers crossed)
  0  
  0  
#4
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-10 06:27:18

@Tony 

This reply is not helpful. all lights are blue, but the device is not functioning properly.

Perhaps this information should be relayed to your dev team.

Thank you.

  0  
  0  
#5
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-10 17:06:58
You said you had to go to your office to get internet. You should be able to connect a PC direct to the modem and get internet, a common way to determine where an internet issue may be. If no internet, then the issue may be with the modem, ISP or your wiring. If you get internet there. then connect your router to the modem and PC to the router. Be sure to power cycle. if it fails, try a different cable, sign on to the router and check the WAN network settings. If the IP address is all zeros, follow the instructions in the post https://community.tp-link.com/us/home/forum/topic/150603 as that is an issue that can occur after firmware upgrade or a factory reset.
  0  
  0  
#6
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-11 16:58:58

i@ArcherC8 

 

I believe the problem is not "no internet", as in "nothing from ISP", but that's the non-tech term being used.

The problem is that the wireless access point does not consistently provide the connection to the SSID.

One or both of the 5 ghz networks will just "disappear" from the wifi ssid availability list on ALL client devices.

 

Other symptoms are it doesn't appear from when you can see the admin pages) that the CPU are working extra hard.

However, the webpages will just sit there blank and after a minute or so become populated with configurated parameters.

Sometimes, the page will just "not respond" according to the browser and you're eventually returned to logon prompt.

  0  
  0  
#7
Options
Re:TP-Link Archer C4000 no longer works after firmware upgrade and reset
2020-10-15 01:22:53
I would consider try reinstalling the firmware or go back to the previous version.
  0  
  0  
#8
Options