Archer A7 - Weak security message on iPhone

Archer A7 - Weak security message on iPhone
Archer A7 - Weak security message on iPhone
2020-09-26 22:30:13 - last edited 2020-10-10 22:18:37

Hello,

 

I just picked up this router and set it up. I'm now seeing a "weak security" message on my iPhone next to my wi-fi stating "WPA/WPA2 (TKIP) is not considered secure. If this is your wi-fi network, configure the router to use WPA2 (AES) or WPA3 security type."

 

Can this be done with this router? I never had this message come up with my previous router.

 

Thank you very much for any help.

2
2
#1
Options
1 Accepted Solution
Re:Archer A7 - Weak security message on iPhone-Solution
2020-09-28 17:24:07 - last edited 2020-10-10 22:18:37

@thebalconyfool 

 

Log into your router and switch your security to AES:

 

 

Apple, along with its new update will show that notification for networks that have compatibility for WPA. I believe the recommended settings are WPA2 AES for the Apple notification not to appear.

Recommended Solution
4
4
#2
Options
21 Replies
Re:Archer A7 - Weak security message on iPhone-Solution
2020-09-28 17:24:07 - last edited 2020-10-10 22:18:37

@thebalconyfool 

 

Log into your router and switch your security to AES:

 

 

Apple, along with its new update will show that notification for networks that have compatibility for WPA. I believe the recommended settings are WPA2 AES for the Apple notification not to appear.

Recommended Solution
4
4
#2
Options
Re:Archer A7 - Weak security message on iPhone
2020-09-28 19:51:45

@Tony That did the trick. Thank you very much for your help. I really appreciate it. 

0
0
#3
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-02 21:40:10

 

thebalconyfool wrote

Hello,

 

I just picked up this router and set it up. I'm now seeing a "weak security" message on my iPhone next to my wi-fi stating "WPA/WPA2 (TKIP) is not considered secure. If this is your wi-fi network, configure the router to use WPA2 (AES) or WPA3 security type."

 

Can this be done with this router? I never had this message come up with my previous router.

 

Thank you very much for any help.

@thebalcon

thebalconyfool wrote

Hello,

 

I just picked up this router and set it up. I'm now seeing a "weak security" message on my iPhone next to my wi-fi stating "WPA/WPA2 (TKIP) is not considered secure. If this is your wi-fi network, configure the router to use WPA2 (AES) or WPA3 security type."

 

Can this be done with this router? I never had this message come up with my previous router.

 

Thank you very much for any help.

yfool 

0
0
#4
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-05 11:39:50

@Tony How do you log in to the router?

0
0
#5
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-06 14:53:46

@cally1 

 

Make sure your computer is connected to the A7 Wi-fi, then open your web browser.

 

Try any of the following to see if your A7 log in page shows up:

 

http://tplinkwifi.net

 

192.168.0.1

 

192.168.1.1

 

The default username is admin and the password is admin unless you changed it.

 

Once logged in, go to Advanced > Wireless > Wireless Settings. You will see settings for the 2.4G and 5G in the middle.

0
0
#6
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-07 16:05:35

@thebalconyfool 

I have a Archer C7 same problem, I assume the setting are same for it

 

thanks

 

0
0
#7
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-07 21:19:42

@iamlost 

 

Yes, same process.

0
0
#8
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-19 13:19:44

@thebalconyfool My A7 is up to date on firmware, it only offers WPA/WPA2 (personal and enterprise)  in the drop down (or No Security)

The advanced security options like AES are not there.

0
0
#10
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-21 16:01:39

@ARBKNY 

 

I am not sure what you may be looking at. 

 

Can you post a screenshot?

0
0
#11
Options
Re:Archer A7 - Weak security message on iPhone
2020-10-30 03:11:33

@Tony Hey there! I tried this and my settings are identical to you screenshot / suggestion, but I'm still getting the message about the weak connection after rebooting via the "reboot" button on the website, then disconnecting and reconnecting on my phone. Did I do something wrong?

Thank you!

File:
70139526-A9B8-4C1D-8595-36D878B2278E.jpegDownload
0
0
#12
Options