Unable to access WD My Cloud NAS behind Deco M5

Unable to access WD My Cloud NAS behind Deco M5
Unable to access WD My Cloud NAS behind Deco M5
2020-09-27 04:46:43
Model: Deco M5
Hardware Version:
Firmware Version:

I am unable to access my WD My Cloud outside of my Deco network. Locally, everything works ok. Didn't have this issue before I switched to using Deco.

 

tried to forward 80/883 to 8080/8883/9080/9883. Didn't work.

 

Any advise?

0
0
#1
Options
6 Replies
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-09-28 21:28:01 - last edited 2020-09-28 21:28:42

@Woosh 

 

What is the model of the device that is connected to the Deco LAN that gives it internet?

0
0
#2
Options
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-09-29 08:34:33

 

Tony wrote

@Woosh 

 

What is the model of the device that is connected to the Deco LAN that gives it internet?

@Tony 

 

It is connected to a modem-router provided by my ISP. It is running a AC1900 chipset.

 

In my precious configuration (before Deco), I was using Asus RT-N13U behind the ISP device and my WD NAS was accessible externally without any configuration changes.

0
0
#3
Options
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-09-29 09:07:38
I’ve also tried to place my Deco in DMZ of my ISP’s device. Didn’t work too.
0
0
#4
Options
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-09-30 20:58:46

@Woosh 

 

If you placed the Deco in the DMZ testing it remotely would not have done anything.

 

Your modem/router is also a firewall, but before doing that test accessing the NAS from the WAN of the Deco by connecting to the network of the Asus, then accessing the IP of the Deco along with the port of the NAS. If that does not work then the Deco is not passing the connection. If you are able to access the NAS, then you need to focus now on the Asus, and do port forwarding for the Deco in the Asus router.

 

What is the IP and subnet of the following:

 

-NAS

-Deco WAN IP

-Deco LAN IP

-Asus LAN

0
0
#5
Options
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-10-02 02:47:38

@Tony 

Connecting to the network of my ISP's modem/router, I am unable to access the NAS direct via IP address of NAS or via the IP address of Deco, along with the port of the NAS.

 

seems like Deco is not passing along the connection.

 

is there a resolution to this?

 

NAS (on Deco network): 192.168.68.113

Deco WAN IP: 192.168.1.147

Deco LAN IP: 192.168.68.1/255.255.255.0

ISP Modem/Router LAN: 192.168.1.254/255.255.255.0


NAS is listening on 80 and 883 (default setting).

 

 

0
0
#6
Options
Re:Unable to access WD My Cloud NAS behind Deco M5
2020-10-02 22:33:50

@Woosh 

 

I think you may need to run the Deco in AP Mode if the port forwarding nor DMZ works.

0
0
#7
Options