Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card

Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card
Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card
2020-09-30 20:54:28
Model: Archer T6E
Hardware Version:
Firmware Version:

Running Windows 10 and this card has no trouble connecting to the 2.4Ghz network, but cannot connect to 5GHz. I've seen lots of comments about trying different drivers, so I installed the Broadcom Driver Version 7.35.317.3 and my issue persists. Windows just says "checking network requirements" then "cannot connect to this network" and returns to the 2.4 band.

 

0
0
#1
Options
3 Reply
Re:Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card
2020-10-01 15:30:14

@derokh 

 

Please try the following driver: https://static.tp-link.com/2019/201911/20191129/Archer%20T6E%20T9E_ASUS%20driver_7.35.351.0.zip

0
0
#2
Options
Re:Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card
2020-10-01 18:52:34

@Tony same problem. Is my hardware bad?

0
0
#3
Options
Re:Won't connect to 5GHz - TP-Link AC1300 PCIe Wireless Wifi PCIe Card
2020-10-02 21:38:19

@derokh 

 

If you happen to have another computer you could try installing the card on that to see if the problem follows the card or stays with the computer.

 

Another thing I would try with the current computer is to boot it up in safe mode with networking. That might work and if it does, that tells you there could be software in the computer getting in the way.

0
0
#4
Options