Archer C59 is now showing week security on all apple iOS 14 devices

Archer C59 is now showing week security on all apple iOS 14 devices
Archer C59 is now showing week security on all apple iOS 14 devices
2020-11-01 02:43:52 - last edited 2021-01-08 00:13:21
Model: Archer C59
Hardware Version: V2
Firmware Version: 2.0.1 Build 20170218 rel.79276

All of my iOS 14 apple devices are now showing week security.  I have my settings set to  WPA/WPA2-Personal.   Version set to WPA2-PSK and encryption at AES.  However the apple devices give a warning of WPA/WPA2 (TKIP) is not considered secure.  I do not have TKIP selected.  I have switched to my older lynksys wifi router with the same AES settings and do not have the security waring on the iOS 14 devices.  Is there a firmware upgrade that corrects this problem?

2
2
#1
Options
10 Replies
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-11-02 23:21:25 - last edited 2020-11-09 22:50:50

@Kevy 

 

If the router is set to WPA/WPA2-Personal and AES there is no reason for the phone to show its still TKIP.  I would forget the network and log back in and see if it changes. 

0
0
#2
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-11-03 22:15:54
Forget network and rebooting of router and devices has been tried with no success.
0
0
#3
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-11-03 22:16:08
Forget network and rebooting of router and devices has been tried with no success.
0
0
#4
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-12-30 01:39:55

@Kevy Same issue. Nothing I try resolves the issues.

0
0
#5
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-12-30 15:10:38

@TP-JP 

 

The PROBLEM the Wireless Setting.

 

Specifically the WPA/WPA2 one. iOS sees WPA first and then issues the message.

 

On my A20 Router I had to make a change to Wireless settings to clear the message:

 

 

You probably have the settings on AUTO for both Versions and Encryption, change them to match the above. That fixed it for me.

 

 

0
0
#6
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2020-12-30 19:40:42
I have triple checked my settings. I have WPA2-PSK and AES selected on both 2.5 and 5 ghz. No auto selection is selected.
0
0
#7
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2021-01-01 15:57:59 - last edited 2021-01-08 00:13:21

@Kevy 

 

Oddly enough, I was just looking at my iPad running iOS14's network settings.

 

I have an Archer A20 Tri-band.The iPad was connected to the second 5Ghz band. It is on channel 157, and I have the settings I posted? On the iPad Wireless I see the 'weak security'??? So I changed to the first 5Ghz band (slower of the 2 5Ghz bands and it can handle both N and AC while the other 5Ghz can handle onyl AC device, and that band in on channel 40?

 

I have no idea why this is or why if is happening?

 

However, in both cases, the 'error message' is never displayed when connecting? Might be due to the iPad doesn't easily display that when connecting? Even a bug in iOS 14.3 or just the iPadOS 14.3?

 

I can tell you though, I was able to make the change on a friends LinkSys router and it fixed it.

0
0
#8
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2021-01-08 00:16:02

@IrvSp  My TP-link replaced my linksys router.  I re-installed my older linkysys router and don't have the security warning.

0
0
#9
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2021-01-08 00:55:03

@Kevy 

 

Compare the SECURITY settings on the two routers. The TP-Link probably has WPA\WPA2 on it.

0
0
#10
Options
Re:Archer C59 is now showing week security on all apple iOS 14 devices
2021-01-30 01:02:21
Correct! My tp-link only has wpa/wpa2 selected. Is that the problem? If so, then this router is out of date.
0
0
#11
Options