Deco S4 Slow WiFi speed

Deco S4 Slow WiFi speed
Deco S4 Slow WiFi speed
2020-11-04 18:58:28
Model: Deco S4
Hardware Version:
Firmware Version:

Just installed the deco S4 (3-pack) system in my home.  I also bought an extra individual S4 unit.  My home internet speed is 300mbps however at the router I can only get about 180mbps.  Im somewhat of an internet noob but is this normal speed or am i doing something wrong?  
 

my goal is to get as close to 300mbps as possible 

0
0
#1
Options
8 Replies
Re:Deco S4 Slow WiFi speed
2020-11-05 23:29:04

@JJohnson05 

 

What speed are you getting when connected via ethernet to the main Deco (the one connected to your ISP modem) 

0
0
#2
Options
Re:Deco S4 Slow WiFi speed
2020-11-10 21:25:14

@Carl 

 

I have the same problem, when I connect it to the Hub ISP( getting 350mb) when I connect the ethernet to the Deco, jumps to under 100mb. What's the problem? This seems to be a very common problem. TP link should fix this.

0
0
#3
Options
Re:Deco S4 Slow WiFi speed
2020-11-10 23:18:34

@Ezuzu 

 

We would need to gather information on your individual issue.  We have no reports that there is a common issue so until our R and D team report this each case has to be handeled individually. 

 

Please provide all the details you can about your network the devices, Hardware specs on network ports, network cards being used, etc.  

0
0
#4
Options
Re:Deco S4 Slow WiFi speed
2020-11-10 23:29:52

@Carl 

 

I tried via Wifi and ethernet same result. I've been reading up on the forums, and the S4 seems to be a common issue to reduce the speed from what I've gathered so far. Could be a firmware issue or entirely something else. 

 

 

0
0
#5
Options
Re:Deco S4 Slow WiFi speed
2020-11-10 23:31:14

@Carl I am using the S4 Deco  on the latest firmware. 

 

I pay for 350Mbps, and have the ISP modem connected to the Deco, when connected directly to the ISP modem. I get over 350mbps, soon as I connect it to the deco, and I wire from the main deco, I get less than 100mbps, wired or wireless. Both the same.

 

 

0
0
#6
Options
Re:Deco S4 Slow WiFi speed
2020-11-11 14:16:29
I do not have an ISP modem, i have my main deco wired via Ethernet directly to the Ethernet wall port. I had my ISP check the speed coming out of the Ethernet wall plug and it was right at 300mbps. I currently have 4 deco S4 units. The main deco plugged directly into the wall pulls between 170-180 mbps but sometimes drops to 70mbps download and 200-225 upload. I used an internet speed tester on my iPhone 11 Pro around the house (2 floor - 4000 sq ft) and the highest I can pull around the house at the other deco units is 60-70mbps upload and 90-100 upload. I have changed the setting from 2.4Ghz to 5, however I didn’t see much change. I currently have the latest firmware update on all of the deco units. I also have swapped the main deco a couple of times for a different unit to see if that helped and it didn’t.
0
0
#7
Options
Re:Deco S4 Slow WiFi speed
2020-11-11 22:20:12

@Carl 

 

is it possible that I would have better results by installing a gaming router and then adding the S4 on top to increase the range?

0
0
#8
Options
Re:Deco S4 Slow WiFi speed
2020-11-12 17:04:29

I have some updates from our Engineering team.  Here are their updates for both of you.  Please see if their suggestions address your concern. 

 

@Ezuzu 

 

It seems the speed is limited by the link speed between the ISP modem and the main Deco S4. Please ensure the cable from the modem to the main Deco is cat5e or above. And you can try to change the cable between the main Deco and modem, change the port on the modem or main Deco for a try.

 

 

@JJohnson05 

 

The 170-180Mbps speed is the wireless speed, for this problem, I think we need to confirm the wired download speed from the ethernet wall port is not having a problem, and then check the wireless download and link speed of the main Deco to have a compare. And check if there are QoS settings on the Deco.

0
0
#9
Options