Problems with new T2U adapter

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Problems with new T2U adapter

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Problems with new T2U adapter
Problems with new T2U adapter
2021-02-05 08:47:03
Model: Archer T2U Plus  
Hardware Version: V1
Firmware Version:

Bought a new T2U From Best buy on the strong suggestion from Wirecutter. The reason for this upgrade is I happen to also have recently gotten a Dual Band AC router.

 

Made sure the T2U supported windows 7.

 

I go to set up the Dual Band Router. Works out great on other computer/phones.

 

I plug and play T2U No drivers. Pop in the CD install the drivers. Able to see the device and scan for wireless but will not connect to my network. My old pre AC network adapter will. I have tried unhooking the old one with no luck. I have tried to get the latest drivers from site, and windows 7 will not take them, and i have moved around the wifi to both front and back USB ports. I have also done multiple reboots. It was able to connect once but at a super low speed once. Any ideas?

 

 

 

 

  0      
  0      
#1
Options
1 Reply
Re:Problems with new T2U adapter
2021-02-05 22:22:19

@Steven1985 

 

Try the drivers from the chipset maker: https://www.mediatek.com/products/broadbandWifi/mt7610#product-downloads

  0  
  0  
#2
Options

Information

Helpful: 0

Views: 413

Replies: 1

Related Articles