AC2600/RE650 (not listed in models!) Very SLOW

AC2600/RE650 (not listed in models!) Very SLOW
AC2600/RE650 (not listed in models!) Very SLOW
2021-02-17 05:41:56 - last edited 2021-02-17 05:45:45
Model: AC500
Hardware Version: V1
Firmware Version: 1.09

First off why does this unit appear unsupported by not including it in the list of products?

 

Second this unit had very slow 2.4 Ghz Wireless so I reluctantly updated the firmware, now the 5Ghz firmware is as slow as the 2,4 Gig. I can not seem to surpass about 15Mbps on any device now either on 2.4 or 5G . Before firmware upgrade I was seeing 29Mbps on speedtest.net (the rated speed of my connection) on 5Ghz. Now I get 10 to 15 on 2.4 and 5Ghz. I always loved and trusted TP link products but this one just soured the milk. 

 

Using in Access Point mode

0
0
#1
Options
3 Replies
Re:AC2600/RE650 (not listed in models!) Very SLOW
2021-02-17 23:45:45

@PDX_Mark 

 

When you put the model type: RE6, and you will see the model pop up. If you typed only RE you will not see the full list.

 

Revert to the previous firmware to see if your speeds are restored.

0
0
#2
Options
Re:AC2600/RE650 (not listed in models!) Very SLOW
2021-02-20 17:58:11
No not true, when I go to post in extenders I get ACXXX ADXX and Archer, None of the AC is AC2600 I think you should be more familiar with your own site and your site should be more user friendly. It looks to me like nobody wants to answer questions about this model, especially why the 2.4G is so slow in access point mode and what I can do about it. Rapidly losing trust for your products
0
0
#3
Options
Re:AC2600/RE650 (not listed in models!) Very SLOW
2021-02-22 22:19:53

@PDX_Mark 

 

Thank you for your feedback.

 

Please reference the story here which will familiarize yourself with our model naming protocols: https://community.tp-link.com/us/home/stories/detail/1594

 

In your original post, you mentioned the extender becoming all-around slow as a result of updating the firmware. Please factory reset the extender by holding the reset button for 15 seconds while it is powered on, and set up the device again. 

 

Make sure the extender is not named the same as your router or you will be doing a speed test to the router which would be further away rather than near the router. You can you the Tether app to change the extended Wi-Fi network so there is no confusion: https://www.tp-link.com/us/support/faq/1373/

0
0
#4
Options