LAN IP keeps changing & unable to set a new one

LAN IP keeps changing & unable to set a new one
LAN IP keeps changing & unable to set a new one
2021-03-02 00:17:44 - last edited 2021-03-03 18:43:22
Model: Deco X60
Hardware Version:
Firmware Version: 1.0.5 Build 20201013 Rel. 64247

It appears that when the power goes out, the X60 will sometimes change it's LAN IP. I've got several IoT devices and servers on my network that are static IP, which are unable to operate on the network when this happens.  To make matters worse, I'm unable to change the LAN IP back to it's previous setting with the error "Failed to save your settings. Please try again later."

 

I've seen several threads on this very forum with the exact same issue and no working resolution or work-around from TP-Link. At this point in time, are there any solutions out there?  Calling this situation frustrating would be a gross understatement at this point.

0
0
#1
Options
1 Accepted Solution
Re:LAN IP keeps changing & unable to set a new one-Solution
2021-03-02 22:18:08 - last edited 2021-03-03 18:43:22

@sclaflin 

 

I've seen two instances that will cause the IP to change:

 

1. If the DNS is set to an IP on the LAN of the Deco, on boot up the Deco will see that as a conflict and then change the LAN to something else..

 

2. When the Deco loses internet and has something else wired to it (switch or any device). The Deco no longer knows what connection gives internet.

 

If it may have something to do with what is wired to the main, try connecting to a satellite node to see if that resolves it.

Recommended Solution
0
0
#8
Options
9 Replies
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 12:43:56 - last edited 2021-03-03 18:43:22
Are you using Address Reservations? That would reserve the IP address for each MAC device. See https://www.tp-link.com/us/support/faq/1795/
0
0
#2
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 13:10:29 - last edited 2021-03-03 18:43:22

@ArcherC8 Thanks for the suggestion. That approach doesn't really work for me. I monitor and maintain several devices. I can't do that when the LAN IP changes arbitrarily.

 

A workable alternative would be for the deco to implement local dns, but it doesn't. I run my own local DNS server, but that too is broken when the LAN IP changes.

 

I think that it's quite reasonable to expect the LAN IP to not randomly change.  I think it's also reasonable to assume that one could actually change the LAN IP without error.

0
0
#3
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 13:57:54 - last edited 2021-03-03 18:43:22

@sclaflin 

 

I am surprised that address reservation would not work but I have a straight forward setup. I use it on several devices that I need the same LAN IP such as my security DVR. The router always assigns the reserved LAN IP address whenever I do a router reset or the power cycles.  

 

My router will assign the other LAN IP addresses as different devices are found for both Ethernet and WIFI. My address reservations are inside of the IP address pool and the other devices overlaps them.

 

Been the same with this router and the other routers from other vendors, I have owned.

 

 

0
0
#4
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 14:47:56 - last edited 2021-03-03 18:43:22

@ArcherC8 Here's a scenario to illustrate: Say I've got an IP camera on 192.168.0.2 and an NVR running on 192.168.0.3. Both the IP camer and NVR are using DHCP with reserved IP addresses at the router. The NVR is set to record RTSP from the camera on 192.168.0.2.

 

When the router decides to change the LAN IP address block to 192.168.4.0/24, both the IP camera and the NVR get a new IP address with their reserved octet.  (192.168.0.2 becomes 192.168.4.2 and 192.168.0.3  becomes 192.168.4.3). While both devices are now operating on the same address block, the NVR is still trying to connect to 192.168.0.2 and fails.

 

Here's another similar scenario if all devices were using DHCP with reserved addresses on the router:  I've got about 30 IoT devices and a management service that helps me wrangle them on my network.  When the LAN IP address block changes, even though all devices have the same reserved final octet, the management software loses connection to all 30 IoT devices.

 

A workable, but less than optimal solution would be if the router implements local DNS.  The NVR could use the DNS name of the camera instead of the camera's IP address.  That way, when the router decides to arbitrarily change the subnet, the NVR could still resolve the IP camera's current address. Unfortunately, the router does not implement local DNS, making this not an option.

 

Again, the router randomly changing the LAN IP address alone is unacceptable, but could be rectified quickly if I could manually set it back.  Since I can't even do that, it becomes a time-consuming and frustrating affair to put my house back in order with the new LAN IP.

0
0
#5
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 16:26:26 - last edited 2021-03-03 18:43:22

@sclaflin 

 

If your outages are frequent and also of short duration, might I suggest a UPS?

 

We are on a different loop than the ISP's h/w for cable delivery. We have Hurricanes and frequent power drops due to many different causes.

 

My Cable Modem and Router are on a UPS (1000W AVR) and my PC's on USP's as well (1000W PFC). During power drops we can continue to use the Internet. The PC's will run out of power in less than 2 hours, but the Modem and Router can last 2 days. During a hurricane, I would use my iPad for the Internet and Cell to call (if I can get it to go though, can be hard during/after a hurricane). Biggest problem I'd have, charging the iPad, which I do have a power bank for.

 

I know it isn't an inexpensive fix, but it can work for you.

 

Not sure why though on a power drop it would change the LAN settings? I know most routers would switch from the default of usually 192.168.0.1 to 192.168.1.1 when being installed if it found another LAN using the default. Sounds odd to me it would switch to what you are seeing? Is there a switch involved in the LAN? I think they can cause problem with router addresses?

0
0
#6
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-02 17:31:04 - last edited 2021-03-03 18:43:22

@IrvSp Sorry, the power outages are artificial.  When I fiddle with house wiring to install IoT relays, I turn off breakers. Occasionally I hit the breaker that is feeding power to the main deco unit.  I didn't want to go into that detail to muddy up the problem I'm trying to describe.

 

There's actually posts on these forums and elsewhere about the Deco LAN IP changing after a restart/power failure - I know I'm not the only one with this problem:

 

https://community.tp-link.com/us/home/forum/topic/244530

https://www.reddit.com/r/HomeNetworking/comments/awtd31/home_network_ip_changed_from_1921680xxx_to/

 

I do have a netgear gigabit switch attached to the router to afford me additional ethernet ports, but it's just a simple plug & play switch.  You're telling me that a switch is going to cause problems for the Deco? I've used this same trusty switch with several different routers over the years with no issues prior.

 

 

 

0
0
#7
Options
Re:LAN IP keeps changing & unable to set a new one-Solution
2021-03-02 22:18:08 - last edited 2021-03-03 18:43:22

@sclaflin 

 

I've seen two instances that will cause the IP to change:

 

1. If the DNS is set to an IP on the LAN of the Deco, on boot up the Deco will see that as a conflict and then change the LAN to something else..

 

2. When the Deco loses internet and has something else wired to it (switch or any device). The Deco no longer knows what connection gives internet.

 

If it may have something to do with what is wired to the main, try connecting to a satellite node to see if that resolves it.

Recommended Solution
0
0
#8
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-03 02:50:17 - last edited 2021-03-03 18:43:22

@Tony Aha!

 

It looks like I assigned a LAN DNS server on the WAN configuration. I've corrected this by setting WAN DNS to external servers.  I also found DNS server settings in  "DHCP Server" and set the LAN DNS there.  Several power cycles later, I've still got the same LAN IP for the router.

 

Might I suggest an error surface when trying to set a LAN DNS server in the WAN DNS settings? Right now, the setting is allowed and problems don't occur until the router restarts and/or power cycles.

0
0
#9
Options
Re:LAN IP keeps changing & unable to set a new one
2021-03-03 18:42:27 - last edited 2021-03-03 18:43:22

@sclaflin 

 

I can forward that feedback. Thank you.

0
0
#10
Options