SLOW SPEEDS on Archer T2U AC600 (US) Ver3.0

SLOW SPEEDS on Archer T2U AC600 (US) Ver3.0
SLOW SPEEDS on Archer T2U AC600 (US) Ver3.0
2021-04-04 12:37:12
Model: Archer T2U
Hardware Version: V3
Firmware Version: Archer T2U(UN)_V3_190315_Win

Archer T2U AC600 (US) Ver3.0 is only reaching 55 Mbps.

 

My internet speed is at 300 Mbps, it reaches that when I connect my PC via LAN cable.

 

What I already tried:

  • install driver version 190116 from https://www.tp-link.com/us/support/download/archer-t2u/#Driver
  • install driver version 190315 from https://www.tp-link.com/us/support/download/archer-t2u/#Driver

 

Both of this driver versions gave out the same result.

 

In the specs sheet, it's written that the adapter can support up to 433 Mbps for 5 GHz band and 200 Mbps for 2.4 GHz band.

 

Is that just a scam or what?

 

Is there even a way to make this get higher speeds?

0
0
#1
Options
2 Reply
Re:SLOW SPEEDS on Archer T2U AC600 (US) Ver3.0
2021-04-06 18:52:41

@Zash 

 

The speeds being "up to" is the key when judging the performance. The real-world speed you finally get can be determined from a variety of factors. Sometimes it can be the computer, the port, the environment. The adapter may be faster on one computer, and not on another or the adapter may be bad.

 

Here are tips to improve wireless performance: link

 

What you can also possibly try is the chip manufacturer drivers: link

0
0
#2
Options
Re:SLOW SPEEDS on Archer T2U AC600 (US) Ver3.0
2021-04-06 19:01:23 - last edited 2021-04-06 19:16:14

@Tony 

 

Test cases done:

 

  1. Desktop computer, wired connection using LAN cable → reached 300+ Mbps, the real speed of my connection plan.
  2. Desktop computer, placed it beside the modem, as close as possible to the Archer T2U → only reached 60+ Mbps max.
  3. Laptop, placed it beside the modem as well, connected via the Archer T2U → only reached 60+ Mbps max.
  4. Mobile phone, Nokia 8 (flagship) → reached 150+ Mbps since that's the limitation of the chip.
  5. Mobile phone, Poco X3 (above midrange, below flagship) → reached 90+ Mbps since that's also the limitation of the chip.

 

So with these tests, my Archer T2U is malfunctioning?

 

Update EDIT: I installed the realtek link you gave and it still gave the same results.

0
0
#3
Options