Archer C6 Wi-Fi Performance Issues

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 Wi-Fi Performance Issues

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 Wi-Fi Performance Issues
Archer C6 Wi-Fi Performance Issues
2021-10-13 22:49:18
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.1.8

I have T-Mobile 5G Home Internet but because of where I have positioned the 5G router, I am extending my coverage with an Archer C6.  I initially had the C6 in Router mode but switched it to Access Point mode to see if that would help my issue but it did not.

 

  • If I connect my laptop to the T-Mobile router via ethernet, I can get a speed test of 400+ Mbps.
  • If I connect my laptop to the T-Mobile router via wi-fi (5 Ghz) I can get a speed test of 400+ Mbps.
  • If I connect my laptop to the C6 via ethernet, I can get a speed test of 400+ Mbps.
  • If I connect my laptop to the C6 via wi-fi (5 Ghz) my speed tests max out around 200 Mbps.

 

Is there a reason why the wi-fi in the C6 does not perform as well as it should?  I've read other reviews of the device online and have seen speed tests of over 500 Mbps.

 

Thanks!

  0      
  0      
#1
Options
2 Reply
Re:Archer C6 Wi-Fi Performance Issues
2021-10-14 21:54:22

@jlillard 

 

When the Archer C6 is connected is it linked to this T-Mobile router?  If so is the T-mobile router's wireless enabled at the same time.  If so and the two routers are in close proximity to each other it could be radio interference.  

Splash into a Smarter Summer - Summer Event and Community Giveaway

Automate and Learn More About Tapo Sub-GHz Sensors, Matter, Apple Home, and Local Smart Actions!

20% Select Sub-G Hubs Available to All Participants! Get Started Here!
  0  
  0  
#2
Options
Re:Archer C6 Wi-Fi Performance Issues
2021-10-14 22:41:37

@Carl What do you mean by linked?  They are connected via an ethernet cable and are about 25 feet apart.

 

I am working with TP Link Support as well and the first thing they asked is if I was using the same SSID for both 2.4 and 5 bands.  I was and split them up for now.  That increased my speed test results to 300 Mbps.  Still not the 400 Mbps I can get through the T-Mobile Wi-Fi but better than before.

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 248

Replies: 2

Related Articles