FTP port forwarding to My Cloud Nas

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

FTP port forwarding to My Cloud Nas

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
FTP port forwarding to My Cloud Nas
FTP port forwarding to My Cloud Nas
2021-12-05 03:20:11 - last edited 2021-12-09 01:34:54
Model: Archer AX50  
Hardware Version: V1
Firmware Version: 1.0.11

I'm trying to set up port forwarding for FTP to my NAS.  On the old router I was able to put more ports in the port range to forward.  i.e. 21,55536-55663.  This router doesn't allow that as the fields aren't big enough and even when I shortened the ports down to 21,536-663 it changed it to 21-663 and didn't work.  The NAS only supports passive mode so if I forward port 21 only it will log in but will time out trying to display the folder list.  It's not forwarding the data ports which by default are 55536-55663.  It will work if I put it in the DMZ but that's not a good solution obviously.  I have two FTP servers running anyway so I need to get this figured out so both will work.

  0      
  0      
#1
Options
1 Accepted Solution
Re:FTP port forwarding to My Cloud Nas-Solution
2021-12-08 17:11:12 - last edited 2021-12-09 01:34:54

@Kevin_Z 

 

So I got it to work.  My issue was that there wasn't enough characters allowed in the internal port field to put the whole port string.  I was trying to manually enter it.  As stated earlier I just needed to leave that field blank and it autopopulated with what was in the external port.  

 

It is now working so thanks for the help.

 

 

Recommended Solution
  3  
  3  
#5
Options
5 Reply
Re:FTP port forwarding to My Cloud Nas
2021-12-06 11:58:45

@Gorbisloth 

 

Hello, if you want to open a port range for the FTP servers, please leave the internal port number is empty. The guide is as follows:

https://www.tp-link.com/support/faq/1379/

 

If that still fails, please show us the error screenshot, we will confirm.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#2
Options
Re:FTP port forwarding to My Cloud Nas
2021-12-06 17:47:07

@Kevin_Z 

 

If I leave the port empty it just autopopulates with whatever the external port is set to.  It will connect but won't retrieve directory listing.

 

Status:    Connecting to x.x.x.x:21...
Status:    Connection established, waiting for welcome message...
Status:    Initializing TLS...
Status:    Verifying certificate...
Status:    TLS connection established.
Status:    Server does not support non-ASCII characters.
Status:    Logged in
Status:    Retrieving directory listing...
Command:    PWD
Response:    257 "/" is your current location
Command:    TYPE I
Response:    200 TYPE is now 8-bit binary
Command:    PASV
Response:    227 Entering Passive Mode (x,x,x,x,x,61)
Command:    MLSD
Error:    Connection timed out after 20 seconds of inactivity
Error:    Failed to retrieve directory listing

 

  0  
  0  
#3
Options
Re:FTP port forwarding to My Cloud Nas
2021-12-08 12:04:57

@Gorbisloth 

 

Please create 2 rules, one is for port 21, and the other is for 55536-55663, then check again.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#4
Options
Re:FTP port forwarding to My Cloud Nas-Solution
2021-12-08 17:11:12 - last edited 2021-12-09 01:34:54

@Kevin_Z 

 

So I got it to work.  My issue was that there wasn't enough characters allowed in the internal port field to put the whole port string.  I was trying to manually enter it.  As stated earlier I just needed to leave that field blank and it autopopulated with what was in the external port.  

 

It is now working so thanks for the help.

 

 

Recommended Solution
  3  
  3  
#5
Options
Re:FTP port forwarding to My Cloud Nas
2021-12-09 01:34:45

@Gorbisloth 

Great job. yes

 

That is what I meant in my very first reply if you want to open a port range, the internal port should be blank.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#6
Options

Information

Helpful: 0

Views: 1581

Replies: 5

Related Articles