Archer C9 v1.0 issues since firmware upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C9 v1.0 issues since firmware upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C9 v1.0 issues since firmware upgrade
Archer C9 v1.0 issues since firmware upgrade
2022-02-01 12:47:07
Model: Archer C9  
Hardware Version: V1
Firmware Version: 3.17.1 Build 20210107 Rel. 55552

Looking for some help and advice on what may be going on. My Archer C9 was solid for 3+ years giving me zero problems. Ever since i upgraded firmware to 3.17.1 Build 20210107 Rel. 55552 it has been dropping connections to some devices. Nothing else has changed (we did not add more wireless devices at home, did not relocate the router, have had same number of devices on 2.4 vs 5 band, etc.). Especially been having problems with Roku sticks and Alexa devices - those disconnect the most.

I checked and it looks like I could revert back to the older firmware, but I wanted to see whether there is something else to try before I do that.

 

Thanks,

Jonas

  0      
  0      
#1
Options
1 Reply
Re:Archer C9 v1.0 issues since firmware upgrade
2022-02-05 22:49:34

@aidasjonas Amigo yo tengo instalado el Firmware 4.1.0 Build 20160517 Rel. 35411 que es del 2016 instale el del 2018 C9(US)_V1_180125, pero no quedo funcionando bien asi que tuve que volver al anterior y se solucionaron todos los problemas

 

Friend, I have Firmware 4.1.0 Build 20160517 Rel. 35411 installed, which is from 2016, I installed the one from 2018 C9(US)_V1_180125, but it did not work well so I had to go back to the previous one and all the problems were solved

  0  
  0  
#2
Options

Information

Helpful: 0

Views: 570

Replies: 1

Related Articles