Strange behavior of Smart Connect and Auto channel selection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Strange behavior of Smart Connect and Auto channel selection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Strange behavior of Smart Connect and Auto channel selection
Strange behavior of Smart Connect and Auto channel selection
2022-02-07 09:38:51
Model: Archer AX10  
Hardware Version: V1
Firmware Version: 1.2.5

I'm trying to understand how smart connect and automatic channel selection works in TP-link routers.

I have an AX10 v1.2 and an AX20 V1, both have the same behavior.

 

Smart connect: They connect the phones to 2.4 and keep them there even if the phone is next to the router and there is no other device on 5GHz.

The laptops connect to 5GHz.

This doesn't look good to me. Why put all the phones on the 2.4GHz band? This is not load balancing nor choosing the fastest band. Also, there is no additional setting for smart connect like in Asus routers, where you set the devices to be moved between bands when the signal gets to specific thresholds. It seems to me this is a dumb implementation, just like choosing channel.

 

I have 3 neighbor APs, 1 on 1, one on 6 and one on 11, signal from therm is between -80 and -70dBm. My router chooses a random channel like 3, 5, 7, 8. Why is that? Is the router just rolling the dice when picking one channel? 

In FAQ , it is stated that 1, 6 and 11 are best, and everyone knows that co channel interference is better than adjacent channel interference. 

 

I'm not even talking about 5GHz channels. Only 36-48 are enabled and all of them are used with 80MHz bonding. Other channels are available in Romania, but TP-link didn't bother to enable them.

 

  0      
  0      
#1
Options
10 Reply
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-09 08:55:54

Hello @Cristi..., thank you for posting on the TP-Link Community. 

 

The 'main' feature of Smart Connect is that the Router determines what Radio the device will connect to, the router will determine which band is best for the device to use when Smart Connect is enabled, while we don't think this is actually a bug. There are different implementations of Smart Connect, some do 'load leveling', that is all radios (dual-band or Tri-band radio's depending on router as well as the guest radio's) will get an even number of devices connected. Some just determine the best radio for the device and will connect to that leaving some radio's having more devices connected than others. Some implementations will also dynamically level the number of devices connected to the radios. If you find your devices are connected to the 2.4GHz instead of 5GHz when Smart Connect is enabled, you are suggested to disable it and connect to the 5GHz manually.

 

Visit this page to know more about Smart Connect feature on the TP-Link router:

https://www.tp-link.com/solution/smart-connect/

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-09 16:26:20 - last edited 2022-02-09 16:27:45

@Kevin_Z 

In theory, the router is doing his magic and everything works well.

In practice, it makes me doubt that it is using a smart algorithm. What's so smart about putting the 3 phones in the same room with the router on 2.4 when there is no other client connected?

I've seen a cheap tenda AC8 that is moving the phone to 5Ghz when it's in the same room with the router and to 2.4 when the 5GHz signal is getting weaker, and back to 5GHz when in the same room. I was expecting the same thing from TP-link. 

Sure, I can choose a channel and turn off smart connect, but what's the point of having a feature which is not working correctly? Most people dislike the way smart connect behaves.

  0  
  0  
#3
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-09 18:42:15 - last edited 2022-02-09 18:42:43

Cristi... wrote

@Kevin_Z 

In theory, the router is doing his magic and everything works well.

In practice, it makes me doubt that it is using a smart algorithm. What's so smart about putting the 3 phones in the same room with the router on 2.4 when there is no other client connected?

@Cristi... 

 

I think you missed what was said?

 

There are different implemenatons of Smart Connect.

 

  1. Device is 'probed' to determine the Band it can/should use.
  2. Router can assign a device to any band it can use that has less devices on it.
  3. Router will 'level' the bands to hold the same number of devices and that may move a 5Ghz device to the 2.4Ghz band and then later back to the 5Ghz band depending on the number of users on a band.

 

First, it is 'smart' in that you don't have to know which band to connect a device to (#1). Of course the other cases above one could call either smart or dumb sad smile

 

In your phone case, without knowing all the other devices connected and the order they connected to the router, it is hard to determine why?

 

On thing though, part of the connection equation could be power of the bands. 2.4Ghz bands go further from the router than the 5Ghz does. However, in general, 5Ghz will have a stronger signal than the 2.4Ghz band at distances far away from the router, but at some point 5Ghz loses power fast and 2.4Ghz would be stronger.

 

If you have a Windows Laptop, Acrylic (https://www.acrylicwifi.com/en/) is a great free tool to see SSID strengths, Channel, and surrounding SSID's. For a phone, check the Phone Store.

 

By the way, I do not use Smart Connect myself. I found it (the router) while managing what goes to which band, I had 5Ghz phones on the 2.4Ghz band shared with slower devices. The phones therefore would not run at top speed.

 

Smart Connect has it uses I think? For those don't want to mess with assigning bands usually, just want a connection, and do not care for the best possible performance on a device. If you know what you are doing, especially if you have a Tri-Band router, I made sure ALL my 2.4Ghz devices ONLY use the 2.4Ghz SSID and that includes my N speed devices by the way, and my AC devices got to the first 5Ghz band and the AX devices go to the 2nd one.

 

Just my thoughts on the subject.

 

 

  3  
  3  
#4
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-10 00:25:39

789626

IrvSp wrote

Cristi... wrote

@Kevin_Z 

In theory, the router is doing his magic and everything works well.

In practice, it makes me doubt that it is using a smart algorithm. What's so smart about putting the 3 phones in the same room with the router on 2.4 when there is no other client connected?

@Cristi... 

 

I think you missed what was said?

 

There are different implemenatons of Smart Connect.

 

  1. Device is 'probed' to determine the Band it can/should use.
  2. Router can assign a device to any band it can use that has less devices on it.
  3. Router will 'level' the bands to hold the same number of devices and that may move a 5GHz device to the 2.4GHz band and then later back to the 5GHz band depending on the number of users on a band.

 

 

@IrvSp 

 

Not to be overly critical but I think it's the other way around and what Cristi has clearly stated more than once is what's being missed.  There are no other clients connected to the router, yet the SmartConnect feature places all phones on the 2.4 GHz band.

 

I myself have observed this behavior with SmartConnect and, as such, keep it disabled.  All the explanations regarding load-balancing and band leveling are irrelevant when it's firmly stated that no other devices are occupying the preferred 5 GHz band.  

 

To completely simplify matters, assume a router with SmartConnect enabled initially has no wireless clients connected whatsoever on any band.  Now introduce a wireless client that supports both 2.4 GHz and 5 GHz (for thoroughness assume 802.11n and 802.11ax compatibility respectively).  Assume this device is within close proximity to the router and has very strong signal strength on both bands. Assume the channels in use for both the 2.4 GHz and 5 GHz bands have little or no congestion and 0% utilization.

 

Under such circumstances, it makes no sense for SmartConnect to repeatedly connect the device to 2.4 GHz instead of 5 GHz.  The ideal behavior would be to prefer the 5 GHz band as that would provide the best performance (arguably the primary reason to invest in a Wifi 6 router).  A neutral policy would be to randomly connect to either band.  However, it makes no sense to repeatedly and consistently connect to the 2.4 GHz to the complete exclusion of the 5 GHz band(s).  There is no load to balance, no channel interference to avoid, no bandwidth contention, no rational justification for SmartConnect to obsessively favor 2.4 GHz. 

 

Yet time and again, this is what happens with several devices when SmartConnect is enabled.  Disabling SmartConnect and maintaining separate 2.4 GHz and 5 GHz networks alleviates the issue by allowing devices to forcibly connect to the 5 GHz band.  But this comes at the cost of (theoretically) being able to automatically switch between 5 GHz and 2.4 GHz bands as wireless clients move in and out of range of 5 GHz radios.  In other words, it's an example of another heavily marketed feature not actually working as advertised. 

 

Aside from the issue of not being able to connect to 5 GHz with SmartConnect, there's also the other matter Cristi raised regarding the auto channel selection not restricting its 2.4 GHz channel selection to the non-overlapping channels (1, 6, and 11).  This is somewhat of a cardinal sin in wireless networking and similarly renders the auto channel selection unusable.

  0  
  0  
#5
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-10 01:08:27 - last edited 2022-02-10 01:10:17

@MikeS21 

 

Well, 'we' do not know the phones in question for one? Might have been connected to 2.4Ghz before even.

 

Sometimes one has to FORGET the network to have it work possibly?

 

Speaking of channels, possible the phone can't handle the 5Ghz channel, seems like Roumania is where he is?

 

Also, 'we' do not know which of the 3 possible implementations of Smart Connect is being used. However, I'd expect TP-Link to use the same code in all router's.

 

Other AP's (routers) are using 1, 6, and 11. His router does not select any of those, right. Stated 'randomly selects' the other channels. I don't think any  Smart Connect implementation will change channels on you once set? So I'll assume the router is rebooted and it chooses a different one each time.

 

Look what is around me:

 

 

I'd also say most of my neighbor's just take the defaults as well probably. Here in my case, one is using 6, 2 using 1, and none on 10 here. I am not sure what Smart Connect would do, but once it set the channel, I don't think it would change. That to me is what needs to be understood.

 

I tried Smart Connect on a different router. I found too often my PC (at the time an AC Speed wireless) wound up on the 2.4Ghz band with other N Speed devices. I assumed it was using Load Leveling so that was the SSID with less devices on it.  That band usually when I ran a speed test could not reach the full ISP speed. Once disabled Smart Connect and used the 5Ghz band I had full speed.

 

Some questions might have been raised that might need answers, but I'd think Smart Connect is working as it should?

 

Still, all problems stated could be resolved by not using Smart Connect.

  0  
  0  
#6
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-10 04:29:53

789626

IrvSp wrote

@MikeS21 

 

Well, 'we' do not know the phones in question for one? Might have been connected to 2.4Ghz before even.

 

Sometimes one has to FORGET the network to have it work possibly?

 

Speaking of channels, possible the phone can't handle the 5Ghz channel, seems like Roumania is where he is?

@IrvSp 

 

I'm not sure why you're going to such lengths to convolute the issue.  The OP clearly has phones that support 5GHz, otherwise there would be no basis for complaining about the Smart Connect failure to connect to 5GHz.  The OP also clearly stated that Romania supports "all" 5GHz channels (and in fact complained that TP Link doesn't properly enable the channels aside from 36-48).  Furthermore, I noted my own independent testing also showed Smart Connect repeatedly prevents several 5GHz compatible devices from connecting to the 5GHz band, even under idealized conditions with all other factors ruled out.  Several other users have posted similar complaints.  These genuine reports shouldn't be disregarded or downplayed with vague notions of load balancing.

 

IrvSp wrote

I tried Smart Connect on a different router. I found too often my PC (at the time an AC Speed wireless) wound up on the 2.4Ghz band with other N Speed devices. I assumed it was using Load Leveling so that was the SSID with less devices on it.  That band usually when I ran a speed test could not reach the full ISP speed. Once disabled Smart Connect and used the 5Ghz band I had full speed.

 

Likewise, your very own responses also confirm that you observe the same behavior whereby enabling SmartConnect reduces performance.  So again, it's very unclear why you're focused on dismissing the feedback and complaints regarding Smart Connect.  It's clearly not very "smart" if most users are compelled to disable it.

 

IrvSp wrote

Other AP's (routers) are using 1, 6, and 11. His router does not select any of those, right. Stated 'randomly selects' the other channels. I don't think any  Smart Connect implementation will change channels on you once set? So I'll assume the router is rebooted and it chooses a different one each time.

 

Look what is around me:

 

TP-Link

 

I'd also say most of my neighbor's just take the defaults as well probably. Here in my case, one is using 6, 2 using 1, and none on 10 here. 

 

With respect to auto channel selection, limiting 2.4GHz networks to non-overlapping channels (1, 6, and 11) allows prevention of adjacent channel interference which is magnitudes of order worse than co-channel interference.  The reasons behind this are beyond the scope of this discussion thread, but I encourage you to research it on your own.  In your example situation, the best choice would be to use channel 11 which is unused.  However, even channel 1 and 6 remain preferable over all the other 2.4GHz channels because the signals from the other networks on channel 1 and 6 are distant/poor (-83 and -87 on channel 1 and -77 on channel 6) and are highly mitigable.  In contrast, interference from adjacent channels is more difficult to alleviate and therefore best prevented by avoiding the usage of overlapping channels.

 

IrvSp wrote

Some questions might have been raised that might need answers, but I'd think Smart Connect is working as it should?

 

Still, all problems stated could be resolved by not using Smart Connect.

 

Again, your statements are contradictory and unfair toward other users.  How can Smart Connect be "working as it should" if the way to resolve all its problems is to not use Smart Connect?  I agree that most users will likely be better off disabling Smart Connect.  But that in no way supports the claim that the Smart Connect feature works properly, and in fact, it implies the exact opposite.

  0  
  0  
#7
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-10 06:30:27 - last edited 2022-02-10 09:59:11

Just to clarify things.

 

The router is a AX10 v1.2 in access point mode.

It is installed in a rural area, the only networks detected are 3 neighbors on 2.4GHz, in channel 1, 6 and 11, at at least 20m away. I believe they are using the modem provided by the ISP, Vodafone, and that model is choosing a good channel. The signal is between -80 and -70dBm. 5GHz has no interference.

 

I tried auto channel. My "smart" router is choosing channel 2, 5, 7, 8... at each reboot, then I gave up and set it on 6. Obviously is choosing channels overlapping 2 networks, not 1, 6, 11, or even 12 or 13. 

In a congested urban area where there are many networks, you may trust the router, but in this case, it's obvious that is not doing it right.

 

Then enabled smart connect, and the router decided to put my Poco X3 Pro, Lenovo M10 plus FHD and an old Samsung J5 2016 on the 2,4 band and keep them there. 

the 2 AC devices were tested at 300-400Mbps on 5GHz and 80Mbps on 2.4. 

How does this mean the router is doing some kind of load balancing or choosing the best band for each device? 

 

Don't tell me to disable smart connect or choose a channel. I already did that. The problem is that other brands have a functional smart connect or band steering, and I was expecting the same thing from TP-link. 

Tp-link smart connect is more like: "If you have no clue how wifi works, just enable it and you will have internet access and one SSID. If you figure out it's not working right, you can disable it."

For sure, all that marketing about smart algorithms deciding what's best for each device it's a lie. 

I also have a AX20 which is behaving the same.

 

  0  
  0  
#8
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-11 13:43:38 - last edited 2022-02-11 13:44:17

@MikeS21  @IrvSp 

 

Thank you both for the thorough discussion and professional suggestions about the Smart Connect function on the TP-Link router. I personally agree that it might not be smart enough based on the actual practice when the phones stay connected to the 2.4GHz network, but I cannot explain more why it happens as I'm not involved in the developing department so I will not know how does the Smart Connect build in the routers.

 

Anyway, @Cristi... if you want this to be further analyzed, I would like to forward your case to the engineering team, they will try to help analyze it and maybe provide a solution for it. Please let me know if you are willing to follow up with them via email. 

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  3  
  3  
#9
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-11 17:26:21

@Kevin_Z 

Sure, I can provide more details and logs via email.

Thank you.

  0  
  0  
#10
Options
Re:Strange behavior of Smart Connect and Auto channel selection
2022-02-15 06:08:22

Cristi... wrote

@Kevin_Z 

Sure, I can provide more details and logs via email.

Thank you.

 

@Cristi...  Done. They will contact you soon, please pay attention to your email box and follow it up. Good day.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#11
Options