Access Point mode not requesting ip address from front router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Access Point mode not requesting ip address from front router

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Access Point mode not requesting ip address from front router
Access Point mode not requesting ip address from front router
2022-02-28 12:38:02
Model: Archer C4000  
Hardware Version: V2
Firmware Version: latest

I reset the C4000 and following on screen instruction to setup password and wifi setting.  It is default to router mode.  I then change it to access point mode.  All the cable connected and wireless device are working fine without an issue.  One problem is that C4000 is not having the LAN Ip address, I run nmap to scan the entire network, there is not a single address belong to C4000.  I am not able to make any configuration change.   By the way, all the devices ip address are all set to main router ip subnet.

 

If I want to make change, I need to disconnect the wan cable from C4000 and power cycle, now I connect my laptop to one of the lan port and make configuration change. After change, connect the wan cable and power cycle again.  It is not very effective.

 

I guess C4000 is not requesting an ip address if it is configure as Access point mode.  In Access point mode, I notices LAN setting is set to smart dhcp which I should use and DHCP server is set to Auto.  I was wondering if DHCP server is set to Auto, it won't request ip address for itself.  I want to change the DHCP server to no, but if I do that I am afraid I may loss access to the router.  

 

Anyone experience the same problem?  Is it a bug to the firmware in access point mode?

 

Thanks

KK Yeung

  0      
  0      
#1
Options
2 Reply
Re:Access Point mode not requesting ip address from front router
2022-02-28 19:12:31

  @sawjai 

 

So for a router with AP mode the network cable would go form the source to the WAN port of the Archer C4000.  This would mean the IP from the source device would be on the internet section.  

 

An easy way to access the router, even in AP mode is through the Tether app.  All you need to do is connect to its WAP and you should be able to then access the router.  

 

Hi, Wi-Fi 7 | TP-Link Wi-Fi 7 Product Launch Event | November 14, 2022 @ 10:00AMPST Watch Live At: https://www.tp-link.com/us/wifi7/event/
  0  
  0  
#2
Options
Re:Access Point mode not requesting ip address from front router
2022-02-28 20:31:32
Carl, I did not add the router in the tether app when I configure router initially. Will I allow to access the router? On second thought, if I set LAN setting to use static IP and disable internal DHCP server, will I able to access the router thru LAN? We try to stay away from using app to configure the router. Thanks
  0  
  0  
#3
Options