Deco X60 Parental Control not working- adult content not blocked

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco X60 Parental Control not working- adult content not blocked

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco X60 Parental Control not working- adult content not blocked
Deco X60 Parental Control not working- adult content not blocked
2022-10-30 22:04:40
Model: Deco X60  
Hardware Version: V4
Firmware Version: Deco X60(US)_V4.6_1.0.1_220412

Just bought the x60 for parental controls. Added three kid profiles and added their android devices to each profile. After which point I tried to access adult website on the chrome browser on their phones and I could still access it each time.

 

I tried to add another profile for myself and added my iPhone- at first it was blocked and working. After I removed and tried again it let the website through. Note i am not trying to block the address explicitly- i am seeing if the category of "adult content" would block it as it is checked. I also deleted, added profile again, cleared cache, rebooted all hardware / phone several times, and checked to make sure i had latest firmware- which it told me I did.

 

Is there a fix for this? Otherwise this thing is going back to the store..

 

Also tried the MAC address suggestion and that did not work.

  0      
  0      
#1
Options
3 Reply
Re:Deco X60 Parental Control not working- adult content not blocked
2022-11-01 00:31:12

  @luv4greenleaves,

I know you said that you have tried the MAC address suggestion, but all the evidence points to Private Addressing being enabled on the devices, remember the setting must be disabled on every client device, or the filter will not apply. 

In your client list, when your phone restarts, does your phone connect as a new device, or does the x60 recognize the device? You should be able to note a difference in both IP address and MAC address.

 

I am also about 90% sure that I read somewhere that it can take time, like up to an hour, for the profiles to take effect on the connections. I can't find mention of it right now, but it would be worth verifying if this is the reason it was not working to its full extent when you were configuring it.

  0  
  0  
#2
Options
Re:Deco X60 Parental Control not working- adult content not blocked
2022-11-01 01:41:59

  @Riley_S 

 

i will try the time suggestion of waiting an HR but the MAC address is just plain dumb. If my child just has to go into settings to change that setting on their phone how secure is that??? That would mean any kid who can search the web will know how to get around it. The Google Nest Wifi platform has safe search that you turn on at the setup level and not tied to MAC... Why can't TP? This must be a joke...

  0  
  0  
#3
Options
Re:Deco X60 Parental Control not working- adult content not blocked
2022-11-04 21:51:53

  @luv4greenleaves tried the Mac address and same thing. Still can access adult content. 

 

Also waited an hour.. no chance..

 

 

Returned and bought W7200 and toy surprise I'm having same exact issues.. I don't understand as I've followed all guides

  0  
  0  
#4
Options

Information

Helpful: 0

Views: 422

Replies: 3