Port Forwarding not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Port Forwarding not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Port Forwarding not working
Port Forwarding not working
2022-11-16 04:04:53 - last edited 2022-11-16 16:29:38
Model: Archer AX1500  
Hardware Version: V1
Firmware Version: 1.3.1 Build 20220401 Rel. 57474(5553)

Hi guys I hope you can help.  I'm having a port forwarding issue.

 

I am running a linux box behind my router and I was ssh/sftp (as well as Plex) access to it.  It's internal ip is 192.168.0.75.  There is a static dhcp map for that computer to that ip/

 

I have set up port forwarding from the "NET Forwarding" Menu to port forwarding. Resulting in this:

 

  Service Name Device IP Address External Port Internal Port Protocol Status Modify
 
Plex
192.168.0.75
32400
32400
All
 
 
 
SSH
192.168.0.75
22
22
All
 
 
The log file shows this:
 

2022-11-15 22:31:03 NAT NOTICE [27078] Virtual server created succeeded[ex-port:22 ip:192.168.0.75 in-port:22 protocol:all]

2022-11-15 22:31:03 NAT NOTICE [27078] Virtual server created succeeded[ex-port:32400 ip:192.168.0.75 in-port:32400 protocol:all]

2022-11-15 22:31:02 NAT INFO [27078] Initialization succeeded

2022-11-15 22:31:01 NAT INFO [27078] Initialization succeeded

 

So this shows that it *should* work I think.  However remote connections time out.  Note both servers respond to local traffic.

 
When I try the ipvoid port scanner I get this:
22 TCP Filtered

ssh

I also tried disabling ma[[ing and tried the dmz setting.  Still everything is coming back as filtered, which I assume means stopped at the router as opposed to refused by the server
 
I did some searching on here for help and found a lot of stuff about private ips from the isp etc, and some other tips on normal setup, nothing was helpful.  Iwill say I do have a public IP so it's not a routing issue.
 
Anyway any help would be greatly appreciated :)
 
EDIT - So I did some more checking about the firmware.  The router got what it called the latest firmware of 1.3.1 Build 20220401 Rel. 57474(5553).  On the tplink support site for firmware download it shows the latest as being Archer AX1500(US)_V1.2_220401 with a publish date of Published Date: 2022-05-16.  the 220401 makes me think its the same but with different version numbers.  I see it fixed port forwarding in a previous firmware.  Maybe I need to try downgrading the firmware?
 
Oh and it only gave me the option of chosing hardware v1 when I posted this message, the router reports hardware v1.2  Not sure if that makes a difference
  0      
  0      
#1
Options
2 Reply
Re:Port Forwarding not working
2022-11-17 07:31:40

@Enesha 

 

Port 22 should be opened by default for the Tether app as stated in this FAQ. So you cannot open it for other services or devices in the local network.

 

How about 32400, is it opened successfully?

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Port Forwarding not working
2022-11-18 04:01:31

  @Liverpool20 

Ok wow that's something to take in.  They take a known tcp port and reuse it for a custom application rather than choosing another non used port? How in the heck is that considered the normal way to do things?

 

Back to focus - I will note the title of that faq is asking why port 22 is testing as OPEN Which I would expect, I suppose, if they are using 22 as their communication port.  However on my router port 22 is showing as filtered when it should show open if it is indeed listening on that port for the application.  Seems like that's a misleading road to go down since it's the exact opposite of my ports being closed.

 

If it is in fact listening on 22, how would I change or disable that?  I didn't ask for an app that would disable (wow super pc here tplink I cant even say cri**le my network cause it's offensive?) my use of my network.

 

I suppose I could change the ssh listening port or do some sort of port triggering.  Tho why I should have to change an established protocol for a custom app is beyond me. Wow

 

Anyway to answer your last question 32400 is not open either

 

32400 TCP Filtered

plex

 So I'm not sure where this leads.  This seems like a pretty big implementation error.  I went with tplink as it seemed to have a good reputation in the linux community so it's hard to fathon they would take something so integrated into the *nix world is crazy

 

I may simply have to return the router and buy something more intelligent.

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 490

Replies: 2

Related Articles