MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network

MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network
MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network
2017-02-20 01:50:10
Model :

Hardware Version :

Firmware Version :

ISP :

I have many computers in my home for my recording studio to a couple of MACBook Pros. I recently added the Archer C3200 which is great but I'm having a strange issue with Text Message Forwarding from my iPhone to my MACs. Text message forwading allows me to send and receive text messages from iMessage form any and all devices that are on the same iCloud account. My issue is that when I am on my TP-Link network via wifi or LAN the iMessage doesn't work. As soon as I connect to my work network which is not TP-Link or a hotel or any other network it works just fine. I can't find any setting that could be blocking this specific service and contacted Apple and they also cannot find any issues with the account. I will take my iPhone and MAC to work tomorrow and again it will start working. I just hoping someone here might have experienced the issue so that I find that I am not crazy and it really exist. I appreciate any ideas and thoughts any of you may have. Understand that I am both a MAC and Windows users so please do make it a slam the MAC users reply :) or vice versa. Thank in advance
0
0
#1
Options
3 Reply
Re:MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network
2017-02-25 01:29:31
Any thoughts on this?
0
0
#2
Options
Re:MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network
2017-03-17 11:29:44
I'm experiencing a very similar issue. I have a TL-WR810N and I'm using it in WISP mode in hotels. Everything including VPN passthrough works as expected except imessages do not get sent or received. When I connect to a vpn, imessages work normally. I have tried changing various settings with no luck including putting my phone in the DMZ and also forwarding the suggested ports for imessage.
I may have found a solution here: https://discussions.apple.com/thread/7376927?start=0&tstart=0. Try changing the DNS on your router to Open DNS(208.67.222.222) or Google's DNS (8.8.8.8)
0
0
#3
Options
Re:MAC OS Sierra Text Message Forwarding failing only on my TP-Link Network
2017-03-17 21:09:47
That is exactly what I did. I changed it on both my wan and lan setting as well as on the router to 8.8.8.8 and 8.8.4.4 and all started working.
0
0
#4
Options