Really Bad Connectivity with Archer T9UH

Really Bad Connectivity with Archer T9UH
Really Bad Connectivity with Archer T9UH
2017-04-29 11:11:58
Model :

Hardware Version :

Firmware Version :

ISP :

I got the Archer T9UH brand new a while ago and I'm on the latest macOS Sierra firmware.

It connects normally, but after about 5-10 minutes or so, it disconnects and says that no adapter is plugged in, even though the light is constantly on for the adapter. The USB slot is working perfectly fine and I have the correct driver installed.

Is it just because of the beta driver? Does anyone else experience this?
0
0
#1
Options
4 Reply
Re:Really Bad Connectivity with Archer T9UH
2017-05-19 02:26:55
I am having the exact same problem. Very frustrating as other Amazon Reviews say the same thing with the intermittent Wifi disconnects.

I also own an archer T4UH - absolutely no problem in the same USB ports and no connection drops!
0
0
#2
Options
Re:Really Bad Connectivity with Archer T9UH
2017-05-19 03:57:44

Johnny_R wrote

I am having the exact same problem. Very frustrating as other Amazon Reviews say the same thing with the intermittent Wifi disconnects.

I also own an archer T4UH - absolutely no problem in the same USB ports and no connection drops!



What OS are you on? I'm facing this problem on macOS, but if it's on Windows as well, then I'd be very skeptical about this product.
0
0
#3
Options
Re:Really Bad Connectivity with Archer T9UH
2017-05-20 16:20:48
Windows 10 64-bit. I'll give it a try on my notebook later to rule out further compatibility issues.

I own the EU Variant of the T9UH by the way.
0
0
#4
Options
Really slow speeds
2017-05-26 01:07:17
I use Windows 10 and I have gigabit internet. I have the tp-link AC2600 router but I only get about 20 to 30 MBS. I have an excellent connection but I can't understand why the adapter is so slow.
0
0
#5
Options