C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country

Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-06-09 00:58:18 - last edited 2019-06-09 01:01:53

I too have the same problem now. My C5400 v2.0 is 2 years old. I have Firmware v1.2.2 Build 20170912 Rel 56240(5553).

 

In addition to the error my 5GHZ-1 is grey. Also, my 2.4GHZ is not visible to my devices even though i said make SSID visible. Note: just before the problem, i could not login to the admin ui. My google home devices started to report they could not connect to the internet. I have about 20 devices on my network. Hoping load is not an issue.

 

So whats the verdict on the solution? Downgrade my firmware? If yes, which version. If not is it factory reset?

 

Anyone know if tplink will replace mine if I log a ticket?

 

Thanks

0
0
#43
Options
Re:Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-08-04 04:49:47 - last edited 2019-08-04 04:51:16

I'm the OP. Ironically tplink "won't" let me login with my email and saying it's not registered. So I had to recreate my ID in order to post. I'm still running with the old firmware - the router is not stable. I need to reboot every couple days to get it working. Also, since I set it as AP, I'm no longer able to login to the router (AP) now. It doesn't look like tplink has updated the firmware ever since. The tech support is useless. I suspect this is a hardware issue that they can NOT fix through firmware update so they are just trying to pretend not knowing this issue at all. What a piece of garbage!

0
0
#44
Options
Re:Re:Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-08-26 19:52:57

It's not isolated to that model. I just went thru same thing with Archer c2300(US).   SUPPORT WAS USELESS, LACKING KNOWLEDGE, AND SUPERVISOR WAS NO BETTER.  

 

0
0
#45
Options
Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-08-27 21:18:23

@djenning 

 

If you have a complaint about support please provide details or contact us at support@tp-link.com  Vauge messaging doesn't help us find issues and improve them.  

 

 

Best Regards 

0
0
#46
Options
Re:Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-08-27 22:03:40 - last edited 2019-08-27 23:29:57

There is nothing "vague" about the poor service. The only way I would know what poor customer service you provide is because I ALREADY did attempt sort things out and my case number is #258630.  Clearly TP Link is downplaying the defective product/software issue that results in the sudden disabling of 5g wireless on multiple models of routers ("unavailable due to restrictions in your country/region") which is ludicrous when it occurs in CANADA/USA where there are no such restrictions.

 

Do you honestly think people come to the forum to complain first, without having tried to resolve/fix things with support?

 

Look at the email chain from the THREE staff, to to see how incompetely your staff handled the situation. After the first two reps poor support/troubleshooting, the matter was escalated.  Marie Corizan Tupaz then said "lf you will only give us a chance to process a replacement for you, l can guaranty you that we will replace it with a working unit".

 
1. First rep didn't troubleshoot properly and issued an rma, even though I explained where it was purchased (third party reseller).

2. I sent the requested docs, and received an email back denying rma because it was purchased from ...you guessed it (a third party reseller), which is exactly what I had TOLD the first rep.

3. With nothing to lose, I did some troubleshooting on my own, and discovered that the FACTORY default 5g security setting was causing the inabiltiy to connect to 5g. At that point everything was working fine and continued until the next day.

4. Next day, 5g was disabled 'due to the country restriction' which should not be the case.

5. Next rep said all TP link can do for troubleshooting a router is, reboot or factory reset. CLEARLY that is not the case since I had done more detailed troubleshooting.

5. Googling, or checking this forum you can see others who encoutered the issue with no resolution other than to return the faulty products or throwing them out. Why is it that your own staff don't know about this issue when it is raised? Downplaying/misleading customers?

6. After raising the poor service concerns, the matter was escalated. l assumed that anyone reviewing the case (Marie) would do their due dilligence that one would expect a customer setvice rep to do, BEFORE offering to replace the router. Had she done so she would have seen the 'third party seller disclosure I noted', but she still offered to replace the item PER THE QUOTED CONVERSATION ABOVE! 
7. She then retracted the offer.....because, wait for it....I purchased it from a 'third party reseller'. 

8. In my experience, with companies that make reputable products that they stand behind, they sometimes make exceptions to  policies...which is what I believe Marie had done, since as she said, she had reviewed the case, and escalated it....so it is a little sleezy to then decline to do what you just offered in the prior email when the customer accepts the offer.

9. I think part of the problem is that you have outsourced your support to people who do not listen, read, or respond properly.

 

I trust that this is more than a "VAGUE" explanation to your assertion of a "vauge" messaging!

0
0
#47
Options
Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-09-09 08:42:40

WHY IS THIS BUG NOT FIXED AFTER TWO YEARS!!???

 

Thanks for putting your source online. You guys are screwed when I push out this fun little application I'm creating for your devices based on your source. Should've just aknowledged the bug and fixed it. It's actually very simple to fix.

 

You should demote your lead dev and qa team to custodial services tbh.

0
0
#48
Options
Re:Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-09-09 12:20:46

Why? Because people who work for TP link can only provide stupid answers like "Carl" did with me. I obviously tried dealing with support before I posted my "vauge" (it's 'vague' Carl!).

 

Hiding behind technicalities like I bought mine from a third party, doesn't negate the company's legal obligation to sell products that last a reasonable length of time, and operate for their intended purpose for that time.

 

This issue of the 5G suddenly disabling for the 'country' issue is known, has been reported for over 2 years.

 

People like Carl, or Marie who offered to replace mine 'if you just give us a chance' and when I tried, she then reneged need to realize that goods sold, MUST operate for their intended purpose for a reasonable length of time...and that length of time is not determined by some arbitrary warranty period the company may offer.

 

This is how class action lawsuits start. Companies KNOW there is an "implied warranty of merchantability" for products they sell, that requires just that. A router should last for more than the warranty period. 

 

1
1
#49
Options
Re:Re:Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-09-09 14:02:06 - last edited 2019-09-11 06:55:38

I took a look at the source code and found a work around for this. I tried it last night. works like a charm

The rule that applies protection against using 5G in restricted countries happens in a part of the code where NO RULES LIKE THIS SHOULD EXIST! These are SIMPLE SOFTWARE DESIGN PARADIGMS.

The error happens when the wireless transmitter SWITCHES CHANNELS, but a specific scenario pushses your router into "Malaysia Mode" (what kind of crap country isn't allowed to have 5G)


**** EDIT **** This was not the complete solution... it's still helpful to fix other issues with the router, but not the full fix.

SOLUTION: 
 

0.5) if you havent already MANUALLY flash your firmware to latest through here https://www.tp-link.com/us/support/download/archer-c5400/v2/#Firmware

  1. Flash/Factory reset your router with the reset pinhole button back to factory 
  2. Plug in ethernet cable directly to the router and the device you will manage it from (very important, we are going to disable wireless from the get-go to get the router in the correct state)
  3. After your router boots up after factory reset, go to tplinkwifi.net to follow the setup wizard
  4. Go through this like normal, EXCEPT
    1. SET YOUR TIME ZONE TO CENTRAL (we'll correct this later if it's not your timezone) 
    2. When you get to the part where you specify your internet connection, there's an "advanced" section button. In that section there is a drop down to specify a country mode. 
      1. SELECT MALAYSIA FIRST, THEN SELECT NONE. this is just to ensure that this drop down wasn't accidently triggered
    3. When You get to the screen to name your Access points and give them passwords. !!!DISABLE ALL OF THE ACCESS POINTS. WE DO NOT WANT WIRELESS ACCESS POINTS ON UNTIL THE VERY LAST PART !!!
  5. The setup wizard should be complete at this point and you should have no wifi
  6. Go to Advanced > System Tools > Time 
    1. Set/replace The NTP Servers to the following below:
      1. 0.north-america.pool.ntp.org
      2. 1.north-america.pool.ntp.org
    2. Select your CORRECT TIME ZONE
    3. Click "Obtain" and let your router (assuming it has access to the internet) obtain the correct time from those new NTP servers 
    4. As soon as it resolves the correct time, click SAVE
  7. REBOOT THE ROUTER USING THE TOP RIGHT BUTTON
  8. Log back in after reboot, go back to time and confirm the CORRECT TIME IS NOW SET EVEN AFTER THE REBOOT
    1. If correct time is not set, redo everything until it can hold the time after a reboot
  9. Go to Advanced > Wireless and let's setup the wifi access points
    1. The main goal of this part is to eliminate any thing that says "AUTO", we want to manually select every option, if we let the router auto select, it will just go back into country restricted mode
    2. On Each access point (2G, 5G1, 5G2), select the LARGEST WIDTH (i think it's 40Mhz for 2G and 80Mhz for 5G... whatever the largest number is)
    3. On Each access point (2G, 5G1, 5G2) select the LAST CHANNEL NUMBER AVAIABLE (I think 2G is 11, 5G1 is 80, 5G2 is 160... whatever the highest number is in those drop downs, use those)
    4. On Each access point (2G, 5G1, 5G2) select AES encryption (probably doesnt matter, but we DO NOT WANT THIS ROUTER TO EVER AUTO SELECT ANYTHING)
    5. On Each access point (2G, 5G1, 5G2) Select an authentication method that suits your password needs (WPA2 non-enterprise is usually the standard)
    6. DONT FORGET TO CHECK THE BOX TO ENABLE EACH ACCESS POINT
  10. Save, Save, Save
  11. REBOOT THE ROUTER USING THE TOP RIGHT BUTTON
  12. Log back in, go to advanced, go to "internet" (i forgot the name of the drop down, writing all of this from memory at work) nd make sure you unselect the checkbox that says "igmp proxying"... we want to disable that
  13. SAVE. 
  14. Make any other changes youd like... (i disable the firewall and anti virus nonsense because its a piece of crap and uses too much of the available memory and CPU)
  15. Save... reboot... enjoy

 

Working without issues last 6 hours. 
If anyone can post screen shots while they do this to help make it easier for more novice users, that would be a..

TREMENDOUS HELP THAT TP-LINK WON'T PROVIDE

Let me know if it works out for you guys as it did for me. 



__________________****EDIT***__________________

This only worked for a few hours and crapped out as soon as a large file was transfered over wifi. I spent the last 4 hours digging deeper.

The underlaying firmware on the wireless radios is the real bug, but the poor quality of the tplink firmware doesn't properly handle this error. 

The c5400 has 3 radios. 1x for 2G and 2x for 5G. In my case the radio that supports 5G-1 kept crapping out, but the error code made it seem like it was turned off due to a country restriction which sent me on a wild goose chase. 

THE NEW WORK AROUND:

 

  1. Login to router and take note of which radio is down (2G, 5G-1, 5G-2).
    1. You can tell this by going to Advanced > Wireless (make sure smart connect is disabled) and see which radio is "greyed out" and cant click it (5G-1 was the issue in my case)
  2. The only way to reset the bugged out radio is to cut power to the router by unplugging it
  3. Boot the router up with out internet connected
  4. Connect via ethernet cable and login to router
  5. Advanced > Wireless
  6. Disable "Smart Connect" (needs to always be disabled from now on)
  7. The down radio should be back up if you cut power to router for reboot
    1. If radio is still down, you'll have to factory reset with pinhole button on back out router
  8. Make sure each radio has a unique SSID
  9. Disable the buggy radio
  10. Save

 

Enjoy only half of the output you paid for, but at least it's stable and you have 5G
 

0
0
#50
Options
Re:C5400 V2 (firmware?) bug: the 5ghz network is unavailable due to restrictions in your region/country
2019-09-09 14:09:51

Now that is VERY helpful. They should pay YOU. I found a simpler solution though. Returned to seller. Go back to Linksys, Belkin, Cisco routers. Problem solved. 

1
1
#51
Options