HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-22 04:04:34 - last edited 2021-10-27 06:16:47
Model: HS105
Hardware Version: V1
Firmware Version: 1.5.8

Hi, 

 

Have four HS105 plugs linked through Alexa and three HS110 plugs also. The HS105 are no longer working, the HS110 do work. 

 

When I try and control one of the HS105 it says "Plug isn't quite ready yet, complete setup in the Alexa App" , I have done that several times and it still says that. 

 

These have been working fine for two years. I have tried disabling the TP-Link Skill and re-enabling it and it has made no difference. 

 

Only change in the environment is a new TP-Link Archer AX73 Wi-Fi router, but that was a couple of weeks ago and these plugs only stopped working yesterday. 

 

Any ideas greatly appreciated. 

1
1
#1
Options
1 Accepted Solution
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do-Solution
2021-10-27 05:58:48 - last edited 2021-10-27 06:18:16

@planetbob99 @RH99 Hello everyone, 

Thank you for your patience.

For HS105 (JP) version reports 'Plug isn't quite ready yet ' error when work with Alexa, our teem did some rectification and this issue should be fixed right now. 

If certain plugs still report the error, please remove them in Alexa app, later disable and enable Kasa skill ( relink TPLINK account in Alexa app)

https://www.tp-link.com/support/faq/2243/

Besides, Kasa devices should be accessible in Kasa app remotely (when phone is using mobile data or connect to non-home Wi-Fi).

Feel free to let me know for any additional feedback.

Recommended Solution
0
0
#11
Options
11 Reply
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-24 11:49:48

@planetbob99 

I also have exactly the same problem. I have more than 10 HS105 plugs, and Kasa Smart switches (HS200,HS210, HS220). I linked the Kasa app with the Alexa app, and everything used to work perfectly. However, since from around Friday, some HS105 no longer can be controlled with Alexa. The Alexa app says, "This device isn't ready to use." I tried with the Smartthings app, and it also cannot find those HS105s.

 

I removed those HS105s from the Kasa app and re-added them, and for some short time, they began to work. But then they went back to the state, "This device isn't ready to use."

 

In the Kasa app, I noticed that those malfunctioning HS105s have a button that says either (ON) or (Off). This is different from what I used to see. Other switches show the power icon, like (1) ... you know, 1 surrounded by 0.

 

I guessed that these HS105s have become "local only" mode. I changed their IP addresses and manually assigned fixed ones, but the situation could not be solved. Actually, they were not "local only". I found out that I can toggle (ON) and (OFF) on the Kasa App from out of my wifi network.

 

Dear TP-link, please investigate this problem, and I hope that it will be solved soon.

2
2
#2
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-24 12:03:02

An update from @RH99 

I found there is one working HS105 in my home. The difference is the working one is with firmware 1.5.6, whereas the malfunctioning ones have 1.5.8 (V1) or 1.0.8 (V2). So, I suspect that there is some bug in the new firmware.

0
0
#3
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-24 12:20:07

@RH99 

 

Yeah, I am sure I updated the firmware recently, as I joined it to the new wi-fi network and would have checked then while in the app. 

 

This is very frustrating, as some of these plugs live in cupboards or behind stuff! 

0
0
#4
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-24 14:19:42

@planetbob99 

Glad to know that I'm not alone. Hope that the fix comes soon!

0
0
#5
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-25 02:00:12

Hello, @planetbob99 @RH99 

Thank you for your valuable feedback and detailed thread, I will check with our team about the possible cause. 

If possible,  can you share the Mac address of the HS105 reporting the 'This device isn't ready to use."  error to us by private message,  thank you. 

0
0
#6
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-25 11:51:33

@Solla-topee 

Thanks for responding. Some of my HS105 have recovered by themselves, but there is one HS105 that still has a symptom.  I will message you the MAC address.

 

I have a (public) question for you regarding the Kasa app.

 

Some of my HS105  shows the power icon (1 in a circle) and some of them show ON/OFF buttons. What's the difference? I noticed that the problem occurs only with HS105s that have ON/OFF button.

 

Thank you.

0
0
#7
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-27 03:52:34 - last edited 2021-10-27 07:27:08

@RH99 Thank you for share the Mac address, I'm still checking the Alexa error message with our team. 

Update: the button with 'ON/OFF' is the new design to make the Status of smart device more clear, in the future firmware, they will unify the button design. This icon does not have relation to the issue. Hope this help clear things out. 

0
0
#8
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-27 04:34:10
@Solla-topee did you get the MAC addresses I messaged over? Not 100% sure the message went.
0
0
#9
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do
2021-10-27 05:48:04 - last edited 2021-10-27 05:48:18

@planetbob99 I got the Mac addresses you shared, thank you! Our team is currently looking into the concern now. 

0
0
#10
Options
Re:HS105 not working in Alexa "Plug isn't quite ready yet" but HS110 do-Solution
2021-10-27 05:58:48 - last edited 2021-10-27 06:18:16

@planetbob99 @RH99 Hello everyone, 

Thank you for your patience.

For HS105 (JP) version reports 'Plug isn't quite ready yet ' error when work with Alexa, our teem did some rectification and this issue should be fixed right now. 

If certain plugs still report the error, please remove them in Alexa app, later disable and enable Kasa skill ( relink TPLINK account in Alexa app)

https://www.tp-link.com/support/faq/2243/

Besides, Kasa devices should be accessible in Kasa app remotely (when phone is using mobile data or connect to non-home Wi-Fi).

Feel free to let me know for any additional feedback.

Recommended Solution
0
0
#11
Options