Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection

Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection
Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection
2022-04-28 13:17:29

Hi all, I have several Kasa cameras installed in our house. When I pull up the cameras on the iPhone app, they appear as online and working, but when I tap on any camera for a live view, it shows up as "connecting". Same result if I turn off cellular and have it on Wi-Fi only. When I turn off Wi-Fi and go to cellular only, everything is working normal. I also have Kasa cameras in another house and those all work normally when I'm connected to my Wi-fi and cellular.

0
0
#1
Options
3 Reply
Re:Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection
2022-04-30 10:50:07

Hello   @jumbo777 

 

If Live view does not load when your phone is connected to the router Wi-Fi network, it should be related to home wifi environment, you could try some tips here

- adjust modem/ router firewall settings or check if any request from kasa camera has been blocked by modem or router firewall 

- reboot camera

- change router DNS settings to 8.8.8.8, secondary DNS to 8.8.8.8, save the settings , reboot router and camera

-Try a different phone

 

If still the same, can I know the model of router and network topology. e.g ISP Spectrum -- router <Wireless> Camera

Can you share the MAC address of camera by private message, app version , model of phone and is Andriod or IOS version, thank you. 

0
0
#2
Options
Re:Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection
2022-04-30 19:07:22

  @Solla-topee Thanks, I'm pretty sure it's with the router settings. I have the Eero pro 6. Not a big deal at home, since I can simply switch to cellular only. In other areas with wi-fi, it's working fine. Thanks for your help.

0
0
#3
Options
Re:Live view on all Kasa cameras not working on my Wi-Fi, but with cellular connection
2022-05-09 09:13:42

  @jumbo777 Appreciated your understanding.  Sometimes it's the firewall from ISP/ Router/Modem affects the ports or requested sent by camera, you could try to adjust firewall settings if needed. 

 

0
0
#4
Options