Wi-Fi 6 TX3000E can’t be detected

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Wi-Fi 6 TX3000E can’t be detected

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Wi-Fi 6 TX3000E can’t be detected
Wi-Fi 6 TX3000E can’t be detected
2020-08-04 19:17:26 - last edited 2020-08-06 01:48:59
Model: Archer TX3000E  
Hardware Version: V1
Firmware Version:

Good morning,

 

after changing my motherboard and processor, the connection card is not recognized nor seen by windows. I already did a BIOS update but it didn't help, I also tried to connect it to other slots but nothing. Solutions ? 

Here are the components of my configuration.

 

MOtherboard : GIGABYTE B450 AORUS ELITE

CPU: AMD RYZEN 9 3900X

 

thank you! 

  0      
  0      
#1
Options
1 Accepted Solution
Re:Wi-Fi 6 TX3000E can’t be detected -Solution
2021-03-01 02:14:39 - last edited 2021-03-12 03:48:40

@Ferraline Hi, 


If TX3000E hardware is not detected device manager, you could the suggestions mentioned in this post first: 
https://community.tp-link.com/en/home/forum/topic/215446

 

If Bios is up to date, you could try a different PCI-E slot, boot up PC in Windows safe Mode ,disable power saving Mode and if that helps.
Please also try a PC with a different motherboard if possible.
 

Recommended Solution
  0  
  0  
#14
Options
20 Reply
Re:Wi-Fi 6 TX3000E can’t be detected
2020-08-06 07:05:13

@Kathy_Z 

 

I have already do it, but without a result... 

  0  
  0  
#3
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2020-08-07 16:41:07

@Kathy_Z 

 

I can not see this device in the device manager, this is the problem... that the device work ( i have tested if on another pc) but my do not recognise a connect device...

  0  
  0  
#4
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2020-08-10 14:08:14

@MxMxx 

 

Hi

Just so you are aware, this adapter is not compatible to Asus Rog Strix Z390 which are onlt 12-18 mths in production !

It also prevents booting into Windows 10 installation, as it has an essential  driver for installation and updating purposes  ( netwtw08.sys ) in direct conflict with my internal wifi.

 

The only  answer in my case was to add this adaptor after reinstallation of Windows 10, which is quite absurd ..

 

It does however create a quicker wifi  connection speed after disabling wifi 1 internal connection , in Device Manager 

 

This is a development issue on the part of TP Link as the bluetooth drivers are also a  problem . 

  0  
  0  
#5
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2020-08-10 14:20:53

@Tweakfiend 

 

thank you for the info! I hope in future that will be supported because is a very good wifi...

 

I was able to get the card to work for a day, after rebooting, it stopped working and was seen by the motherboard. 

I opted to buy a competitor's wifi card at a lower price and of lower quality/speed to remedy the problem, although I'm sorry as this wifi card with my previous configuration gave very good results...

  0  
  0  
#6
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2020-12-02 15:51:41

@MxMxx I have the same problem although different motherboard and processor the brands are the same. Mine is Gigabyte Aorus B550 Elite with an AMD Ryzen 5 3600 with the same WiFi adapter TX3000E. Still have not come across a solution yet but I found out that after upgrading to the latest update and upon the first boot to Windows 10 the WiFi adapter was detected, was also detected with soft reboot (restarting without turning off the power) but was undetected again after a hard reboot (shut down, unplug then plug back the power and turn on).

  0  
  0  
#7
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2020-12-30 02:53:19

@Kureiton 

 

Thanks for reporting the issue to the community again. Have you tried the suggestions we provided here?
https://community.tp-link.com/en/home/forum/topic/215446

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#8
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2021-01-02 20:49:46

@Kevin_Z 

 

I'm having the same issue. Works after installation in both pci-ex1 and pci-ex4 but then disappears and shown as hidden device and reported as disconnected.

 

Bit dissapointing as it's quick when it works. Back to old USB adaptor. Guess we are waiting for a USB Wifi6 adapted to be released.

  0  
  0  
#9
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2021-01-04 11:35:25

@SimonAus 

 

Hi, can you also try the suggestions we provided here?
https://community.tp-link.com/en/home/forum/topic/215446

 

Please then help check the system info of the computer as well as the driver version, we will try to investigate further: https://www.tp-link.com/support/faq/2722/.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#10
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2021-01-17 12:17:58
I am also running a usb TP link wifi 5 adapter ( WL-WN821N ) on my self built PC using MSI B450m mortar mobo with a ryzen 5 2400G proc. The wifi adapter also occasionally drop the connection and occasionally during a boot, win10 ( 64 bit ) will prompt 'cannot detect the USB adapter ( WL-821N ) and I will have to pull out and plug it back into the USB port to get it detected again. I have confirmed all my USB ports are ok so this also look like a TP link issue. I am intending to replace this adapter with the PCIe TX300E but now I am having a second thought after reading all these issues with the TX3000E. Not sure if problem is happening only on AMD based PC or not.
  1  
  1  
#11
Options
Re:Wi-Fi 6 TX3000E can’t be detected
2021-01-22 11:05:15

@kmh 

 

Hello, may I know the hardware version of the TL-WN821N? Is it v6?


If its hardware version is v4/v5/v6, you may try the latest public driver:
https://static.tp-link.com/2020/202006/20200601/00015960-RTLWlanU_WindowsDriver_1030.38.0712.2019_Drv_3.00.0032.L.zip

 

You need to uninstall all the other drivers for this adapter, then install it manually: https://www.tp-link.com/support/faq/920/.

 

Just to confirm, what is the model number of your wireless router? You may run a Wi-Fi analyzer on the PC to verify which channel is busy and which is clear for the network, then choose a clear channel on the router, change the channel width to 20MHz, then reboot both the router and the PC to confirm.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
  0  
  0  
#12
Options

Information

Helpful: 0

Views: 5954

Replies: 21

Related Articles