Solution - How to set up ER605 with 2 WAN's

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Solution - How to set up ER605 with 2 WAN's

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Solution - How to set up ER605 with 2 WAN's
Solution - How to set up ER605 with 2 WAN's
2023-05-12 17:25:41 - last edited 2023-05-15 06:27:26
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.1.2 Build 20230210 Rel.62992

I had a lot of trouble getting the ER605 to work with 2 WAN's - in load balancing mode or in failover mode.

 

My trouble was that I had double NAT mode on both WAN's circuits as it wasn't easy/possible to set the ISP provided routers to 'modem only' mode 

 

My set up is:

ISP router 1 --> ER605 (on 192.168.1.0/24)

ISP router 2 --> ER605 (on 192.168.8.0/24)

ER605 had main LAN as 192.168.101.0/24

 

NB. I am using the Omada Hardware Controller OC200

 

Setup: Settings --> Wired Networks --> Internet

 

WAN Mode:

WAN Ports: WAN and WAN/LAN1 checked, others unchecked.

 

Test 1

Load Balancing Mode
 

Application Optimized Routing: Checked

Link Backup: Not checked

 

Test 2

Failover Mode

 

Application Optimized Routing: Checked

Link Backup: Checked
Primary WAN: WAN

Backup WAN: WAN/LAN1

Backup Mode: Always Link Primary
Mode: Enable backup link when any primary WAN fails

 

All other settings set at default

 

Setting up the ER605 for both was fine and worked beautifully in both balancing and failover modes. I thought I'd nailed it.

But, the ER605 didn't notice when one of the lines went down and Internet access was lost on the LAN.

Solution:  

 

Go to Devices --> ER605 click the row and a window opens on the right.

Navigate to Config and scroll down to Advanced, open the option.

In there, you will see an option call Echo Server.

 

The option is Auto by default.

From what I understand, it will go off looking for the DNS server on each WAN port and PING it.
In my case the DNS servers were set as 
192.168.1.1 and 192.168.8.1 respectively (the address of my ISP's routers)

Both routers were still up, even when the internet went down so the PINGs will always suceed.

So, I set the option to Custom and put a well-known public DNS server in the field and the whole set-up worked. The ER605 now stops using the WAN where the PING doesn't respond. You still get a short loss of internet connectivity but it recovers fast. 

There are many public DNS server, but I guess 8.8.8.8, 8.8.4.4, 1.1.1.1, 1.0.0.1 are the most famous... Google 'public dns server ip' and make your choice.

  6      
  6      
#1
Options