Open VPN - No routing

Open VPN - No routing

Open VPN - No routing
Open VPN - No routing
2024-01-28 09:49:58 - last edited 2024-02-02 02:41:48
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.2.3 Build 20231201 Rel.32918

Hi guys,

 

I use the ER605 as router (not behind an ISP router) and I can establish an OpenVPN session. It is recognized at my android 14 device as well as within omada.

Unfortunately I can't access neither my local devices/servers nor the internet, when openVPN is activated on my mobile device.

I also see a strange info in the routing table: tun_server0

 

The open VPN Setup looks like this:

 

 

 

I'm also using NO-IP as dynDNS service. This also works fine.

 

 

Is this an omada or Android problem? With my previous phonesuch a setup worked as intended.

  1      
  1      
#1
Options
1 Accepted Solution
Re:Open VPN - No routing-Solution
2024-02-02 02:41:44 - last edited 2024-02-02 02:41:48

Anyone who is using Android and experience the issue with OVPN, you might find it helpful:  Solution - No Traffic After OpenVPN Is Connected - Android OpenVPN Connect 3.4.0 Update 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  1  
  1  
#31
Options
31 Reply
Re:Open VPN - No routing
2024-01-28 16:43:38

  @Pras71 

 

Your issue is likely the Subnets you are using.

 

On you home network, the router LAN network Subnet is 192.168.0.x/24

The Open VPN Server settings also us the same Subnet. Change the IP Pool to a different Subnet:

 

Private Subnets:

Class A = 10.x.x.x

Class B = 172.16.x.x

Class C = 192.168.x.x

 

Suggested Settings:

LAN Network = 192.168.0.x/24

Open VPN Server IP Pool: 172.16.0.x/24

 

Once you make that change you can run into one more issue:

 

If the remote network (Client Side) uses the same Subnet as the home network (Server Side), connections might not work when you have Tunnel Mode set to "Split". If a device in the remote network has the same IP as a device in the home network, you will have connection issues. Switching Tunnel Mode to "Full" will route all traffic over the VPN avoiding this issue, but this means you will be using your home Internet from a remote location which can slow things down if you have slow ISP speeds.

 

I run into this issue when I visit my Sisters house. My network and their network are both using the 192.168.1.x/24 Subnet.

  0  
  0  
#2
Options
Re:Open VPN - No routing
2024-01-28 17:31:42

  @Pras71 

 

I seem to be having a similar issue to you on my ER605 V1 with (at least) my Android 14 phone.

 

My VPN is reporting a connection (at least from the client side) but the speeds are incredibly low (a few bites per second).

 

I suppose this could be an issue with the OpenVPN app. I did have to make a manual change to my OpenVPN configuration file as well since I use CloudFlare for DDNS and my Omada router is behind the ISP one. The ISP router could also be a cause as I have not fully ruled that out yet.

 

What I do know is that it was working 1-2 months ago. I don't know if it was related to an update of the client application or the router firmware upgrade. 

 

I also do know it is not related to the client's network. I have confirmed this behavior on two separate WiFi networks with different IP schemes as well as a cellular connection.

 

I have been meaning to dig into this more, and will try to do so in the next few days.

  0  
  0  
#3
Options
Re:Open VPN - No routing
2024-01-28 17:50:17

  @HellBent 

Thanks to your replay. I'm not sure if this related to my subnets. I had a simliar configuration with my previous mobile phone and it worked. Anyhow, I will play around with different subnets to see if there is any effect.

  0  
  0  
#4
Options
Re:Open VPN - No routing
2024-01-28 17:50:36

  @infinitytec 

 

VPN connections rely on Upload speeds. During the Covid Pandemic my company sent us all home to work from home. We needed to use a VPN to connect to the work network. At the time I had Charter (Spectrum) Internet with 300 Down / 10 Up and my VPN connection was so slow it was unusable. I then upgraded to a Fiber provider with 500 up and down and my VPN speed issues went away.

 

Also, Most COAX (Cable) ISP's have moved to Modem/Router combos. If you also have you own router this will put you in a "Double-NAT" situation. Iternet access will likley be fine, but anything that needs a WAN to LAN connection might not get routed correctly. You will know if you are "Double-NAT" if your ER605 is getting a local IP for it's WAN address. If this is the case for you, contact your ISP and asked them to place their router in "Passthrough Mode". That will allow the ER605 to get a public WAN address and solve your routing issues.

  0  
  0  
#5
Options
Re:Open VPN - No routing
2024-01-28 17:51:41

  @infinitytec 

Thanks for your feedback. I will try to use another phone with an older Android version. I will come back with the results (maybe in a few days)

  1  
  1  
#6
Options
Re:Open VPN - No routing
2024-01-28 17:54:38

  @Pras71 

 

On your androind phone, the Default Google VPN might be turned on. On your phone, when NOT connected to OpenVPN, if you see a Key icon to the left of the WiFi and Celluar icons, then Google's or another provider like Duck Duck Go VPN is activated. Double VPN's could conflict with each other.

  0  
  0  
#7
Options
Re:Open VPN - No routing
2024-01-28 17:57:30

  @HellBent 

 

I have a fiber connection and openVPN worked good enough in the past. I don't have this double NAT scenario, because my provider only sent me a fiber-to-ethernet modem (which is fine for me), so I really use the ER605 as the only router in my setup. My old phone broke down, so i got a new one. I didn't try to reuse the old openVPN setting (because the setup was so easy the first time), but just created a new one for my new phone, which didn't turn out so easy as the first time.

  0  
  0  
#8
Options
Re:Open VPN - No routing
2024-01-28 18:13:01

  @HellBent yep, I understandthar, and I don't think I made any configuration changes that would impact this. I have reliable speeds at both ends and have tried on numerous occasions. Thus has only been a problem for a few weeks.

  0  
  0  
#9
Options
Re:Open VPN - No routing
2024-01-28 18:17:14

  @infinitytec @HellBent

 

I just grabbed my wifes phone with android 13. It the same issue here. openVPN connection established but no routing to internal devices or to the internet. it really looks like an internal routing problem with the openVPN connection.

Additionally I tried a total different IP range e.g. 10.10.0.0 but with no different effect. I'm at a loss here. It can't be that difficult since I already got it working in the past.

Any ideas regrading that strange routing table entry?

  1  
  1  
#10
Options
Re:Open VPN - No routing
2024-01-28 18:18:33

  @HellBent I have a Samsung phone with Android 14. I typically run a local DNS-based adblocker that uses VPN and disable that when attempting an OpenVPN connection. 

 

As far as I can tell, Android does not allow simultaneous VPN connections.

 

I am able to successfully connect to OpenVPN and my device gets an IP address, but no traffic is being routed.

  0  
  0  
#11
Options

Information

Helpful: 1

Views: 2272

Replies: 31

Related Articles