Deco m4 Ethernet and wireless capped at 100 Mbps

Deco m4 Ethernet and wireless capped at 100 Mbps
Deco m4 Ethernet and wireless capped at 100 Mbps
2020-01-03 21:49:20 - last edited 2020-02-24 11:48:30
Model: Deco M4
Hardware Version: V1
Firmware Version: 1.1.0

Hello, I know there's been a few posts on this subject but the only solution I've seen is that someone will email you.   I replaced my existing router with a deco m4.  My Rogers Hilton modem goes in the M4 and the m4 goes to a switch.  The switch says it's only connected at 10/100 but all my other connection to the switch are at 1000 Mbps.  The cable is the same cable that went to my other router and I was able to get close to the 500 Mbps I pay for.  How do I get the M4 to connect at 1 Gbps through Ethernet?

thanks

0
0
#1
Options
1 Accepted Solution
Re:Deco m4 Ethernet and wireless capped at 100 Mbps-Solution
2020-01-09 02:23:03 - last edited 2020-02-24 11:48:30

@Imee1976 

 

Hello, please verify the model number of your Deco product. It seems that it is Deco E4(Deco E4R), not Deco M4.

 

For your information, the Deco E4 has the 10/100Mbps LAN ports. 

https://www.tp-link.com/support/download/deco-e4/#specifications

 

May it help. 

Recommended Solution
0
0
#6
Options
17 Replies
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-01-06 09:18:10

@Imee1976 

 

Hello, what is the model number of this switch? 

 

Please connect your computer to the Deco M4 directly, bypass the switch and then test the wired speed you can get. 

 

In the meantime, please click here to get the wired negotiation speed. 

 

Besides, you can change another ethernet cable or device; And you can change the slave Deco as the main Deco to test the speed. 

https://www.tp-link.com/support/faq/2400/

 

May it help. 

0
0
#2
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-01-08 20:28:48

@Kevin_Z  I've connected the deco m4 directly to my laptop and it still connects at 10/100.  When I comment my laptop to the switch it connects at gigabit speeds.  

File:
213BCA0C-078C-4990-85EA-BA354DB1CDD8.jpegDownload
0
0
#3
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-01-08 20:34:03

Here is the deco speed I couldn't post two pics in one post 

File:
06481673-1FD5-4F40-A970-A8EF4802383B.jpegDownload
0
0
#4
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-01-08 20:36:49
I’ve reset the decos and I’ve tried all decos as main and no luck. I replace the decos with my old netgear router and I get my regular connection. The decos are now set up as AP and are still connecting to the switch as 100Mbps
0
0
#5
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps-Solution
2020-01-09 02:23:03 - last edited 2020-02-24 11:48:30

@Imee1976 

 

Hello, please verify the model number of your Deco product. It seems that it is Deco E4(Deco E4R), not Deco M4.

 

For your information, the Deco E4 has the 10/100Mbps LAN ports. 

https://www.tp-link.com/support/download/deco-e4/#specifications

 

May it help. 

Recommended Solution
0
0
#6
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-02-26 07:56:33

@Kevin_Z 

 

Hi

 

I'm facing the same issue with my Deco M4 (M4R) with the latest firmware.

Its connected to my broadband modem using a Cat 6 ethernet cable and I only get 100Mbps speed.

When I connect to my broadband modem directly then I'm receiving speeds upto 200Mbps.

 

Followed the troubleshooting steps but it didn't help!

 

Thanks

1
1
#7
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-06-07 16:11:20

@Kevin_Z I have the same problem. Is this because the Ethernet speed is improperly negotiated between the modem and the Main Deco. I'm using a Huawei HG8145V modem that gives me 300 Mbps directly (before connecting Deco). However, once I connect the Deco network the speed drops to less than 100Mbps. 

 

I'm using the latest firmware.

 

From the responses in the forums, I have not seen a satisfactory solution by TP-Link. Please help us solve this. 

0
0
#8
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-06-22 05:28:54

I used a LAN cable to connect the M4 and got the speed up to 900Mbps. But when I connect with my macbook pro (2013) and my iphone7 at a close range to the M4, the max speed I can get is 90Mps. This issue is really annoying me.

1
1
#9
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-06-27 03:08:36

Same here.

 

Modem > (cat6) > Main deco > (cat6) Slave Deco.

 

I get 240Mbps (my contracted ISP speed) connected via WiFi to the main Deco, but only 100Mbps on the Slve Deco.

 

Done it all I could read in the forums (QoS, DNS, Reset Priority, etc), but no success.

 

Any ideas?

I have the M4R, so pretty sure it was supposed to handle gigabit speeds.

0
0
#10
Options
Re:Deco m4 Ethernet and wireless capped at 100 Mbps
2020-10-10 21:10:55

@Imee1976  Exactly the same problem. Direct connection to switch, 1000 mbit from one computer to another. Put the Deco M4 in between, 100 mbit only. I think the M4 doesn't play nicely with many switches. Pity. Next time I'll spend a bit more money. 

1
1
#11
Options