TL-WPA4220 looses internet connectivity after few days of uptime

TL-WPA4220 looses internet connectivity after few days of uptime
TL-WPA4220 looses internet connectivity after few days of uptime
2020-01-04 09:26:20
Model: TL-WPA4220
Hardware Version: V4
Firmware Version: 4.0.3 Build 20190326 Rel.43406

I've been using the TL-WPA4220 device for a few weeks now and I noticed that every few days it loses connectivity to the internet. This is apparent in two ways:

  1. Any device that attaches to it wirelessly is unable to access the internet
  2. The web interface of the device cannot be accessed over the browser.

 

The solution to this is to unplug the adapter and plug it back in, after which it successfully establishes the connection and works properly for days until the same issue reoccurs.

 

As you may imagine, this gets very annoying. How to resolve this issue?

 

Some steps I tried so far:

  1. Setting the static IP address for device to obtain from the router (didn't work)
  2. Upgraded firmware with a proper version in the proper region (didn't work)
  3. Tested all devices in house to determine if they are the cause of this, didn't produce any change in behavior
  4. Setting up a continuous ping from each device (didn't work)

 

I would appreciate any other idea besides these as I am right now in front of a wall. My next resort is to simply claim device under warranty or ask for money return.

2
2
#1
Options
37 Reply
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-01-07 07:19:09

@MK86 

 

What is the light status of the TL-WPA4220KIT when the connection drops out? Please check the IP address and default gateway with your device connected to the powerline adapter.

Note: Here is the instruction:https://www.tp-link.com/support/faq/838/

 

At the same time, can you get internet from the main router by wired cable? 

 

You can change another socket to plug the adapters and try to change another ethernet cable to connect the main adapter to the router.

 

Besides, you can locate them in the same room and verify whether it works stable as expected.

 

Any updates, please let us know.


Have a nice day. 

0
0
#2
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-01-13 19:09:21

@Kevin_Z 

Hi, 

i have the same Model: TL-WPA4220

Hardware Version: V4

Firmware Version: 4.0.3 Build 20190326 Rel.43406

 

And almost every day i need to unplug and restart the adapters.

what is interesting there is no firmware with this number/date on the official paget to download ?!?

Meaybe we shoud downgrade the firmware?

 

BR 

0
0
#3
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-02-03 02:24:27

I am also having this issue with the TL-WPA4220Kit, the wireless module drops out, initially I can see it on the tpPLC app on my phone, when I notice an issue with a device supposedly connecting to the wireless extender, I have checked the app and it is not there, a restart of the extender seems to fix this.  How do I find out what the firmware is on the extender, not sure if it needs to be updated.  Note, trying to update via the App comes up with unable to connect to the firmware site, the wireless extender is connected via powerline to the lan version of the kit which in turn is connected to the router.

1
1
#4
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-02-08 04:09:33

@MK86 @Kevin_Z @clunker @RagDaz 

 

Hi,

I have exactly the same problem. After a day (sometimes later, sometimes earlier) WiFi network disapears. The connection through ethernet cabel  is still working. So it's something wrong with WiFi functionality I guess.

Have you found any solution, please or should I send back the device as not working?

Firmware version: 4.0.3 Build 20190326 Rel.43406

Hardware version: TL-WPA4220 v4.0

 

TP-LINK Team, could you be so kind and adise what should I do to use your product?
 

0
0
#5
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-02-08 22:31:50

@MK86  I got this device to watch TV in the front of the house as I got buffering with the main router, because I got disconnects when I mirrored the Main Router AP details I ended up creating a new AP this seems to have fixed the issue as it works fine with the TV.  I did wonder if the original issue was IP conflict as my main network is DHCP and devices connect and disconnect as family members come home and leave, however I noticed that you tried a Static IP and it still did not work, however just a thought - whilst you used a Static IP could the IP already be allocated to another device?

0
0
#6
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-04-23 15:11:04

Anyone using firmware V4_190326 and experiencing the symptoms described in posts 1-5 above may want to consider downgrading to the previous firmware version. I downgraded from TL-WPA4220(EU)_V4_190326 to version TL-WPA4220(EU)_V4_180308 and it seems to have resolved all of these issues.

 

Initially I upgraded firmware to version TL-WPA4220(EU)_V4_190326 when the product was brand-new and until recently had only tested with that version. Every 6 or 7 days the device would become completely unresponsive and had to be power cycled to restore normal operation. It also became increasingly unstable in the days leading up to the 'crash' and frequently lost internet connectivity for a minute or two. Since downgrading I haven't noticed any problems after several weeks of up time.

0
0
#7
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-05-06 11:48:47

@MK86 I am having the exact same issues as everyone else, I have to restart the adapter every day as I lose all internet connectivity whether I am connected to it via cable or wireless.

 

I am going to try to downgrade the firmware as suggested, but where do you get the older firmware from? On the TP-Link site it only offers the latest version to download.

0
0
#8
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-05-06 12:10:13

@kamakazi999

kamakazi999 wrote

@MK86 I am having the exact same issues as everyone else, I have to restart the adapter every day as I lose all internet connectivity whether I am connected to it via cable or wireless.

 

I am going to try to downgrade the firmware as suggested, but where do you get the older firmware from? On the TP-Link site it only offers the latest version to download.

If you get a reply to your question can you post on here I am having same issue and it's driving me bonkers!! I had older version of this device and gave it away to a relative to help them with wifi issues round the house during this lockdown I ordered a new one and assumed I would get something stronger and more reliable!

0
0
#9
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-05-06 13:32:02

@kamakazi999 try this link to the polish site I downloaded the older version from there and installed it here's hoping it works!

 

https://www.tp-link.com/pl/support/download/tl-wpa4220kit/#Firmware

0
0
#10
Options
Re:TL-WPA4220 looses internet connectivity after few days of uptime
2020-05-06 13:37:02

@LennyK thanks for the link, will give it a go.

 

I have also been speaking to TP-Link support on chat and they are going to do some testing with the firmware and they did offer a RMA on the adapter, but I am not conviced that this is a hardware issue.

0
0
#11
Options