TAPO C200 Sound feedback

TAPO C200 Sound feedback
TAPO C200 Sound feedback
2020-05-17 07:54:56 - last edited 2020-05-17 07:56:21
Model: Tapo C200
Hardware Version: V1
Firmware Version: 1.0.7

I've tested the "voice call" feature of the C200 from the app.

 

When I say "hello" into my phone, after a short delay I can hear my own voice back on the phone.

Meaning, I say Hello, the C200 speaker says Hello, then the C200 microphone picks up the Hello I just emitted (that's the problem), and it is played back to me on my phone.

This is then followed by a few echo sounds.

 

I was definitely in a room far away, to be clear.

 

Aren't microphones supposed to filter out sounds emitted by the same device? Is this a bug? Or something I have to live with?

0
0
#1
Options
3 Replies
Re:TAPO C200 Sound feedback
2020-05-20 02:57:06

@nasht00 

This sounds not to be camera hardware or firmware issue, as we generally need the two-way audio function when we are not near the camera. According to your description, it seems that your phone and your camera are close to each other and that's why the camera can 'hear' the echo on your phone.

 

If your phone and your camera are far away from each other and you do encounter the echo issue, you may record a video showing the echo issue and contact the camera support to seek some solutions.

Best Regards.
0
0
#2
Options
Re:TAPO C200 Sound feedback
2 weeks ago

@nasht00 I have the same issue on my unit Tapo C200. I was at my office and the C200 is at home and when I use the Voice Call feature, I get terrible feedback.

 

Any solution to this @Tplink?

0
0
#3
Options
Re:TAPO C200 Sound feedback
2 weeks ago

@Deano86 

Hi, sorry for the delay.

For the terrible feedback, did you mean there would be a long delay, or the voice from the camera side is very noisy and unclear or barely recognized?

How long have you had the camera and when did this issue start?

 

Thank you very much!

0
0
#4
Options