Archer C6 losing internet connection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Archer C6 losing internet connection

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 losing internet connection
Archer C6 losing internet connection
2021-02-09 13:58:05 - last edited 2022-02-08 09:11:11
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.3.6 Build 20200819 rel.50735(4555)

Hello, 

 

After recently upgrading the firmware version to the latest one my router keeps losing internet connection to the 2.4 network and all my smart devices have to be manually reconnected every few hours. This does not seem to affect the 5G network or the LAN devices, they work perfectly fine. I am in no way an expert so I am going to try my best to explain the behavior I have observed so far:

 

1.The 2.4 network keeps broadcasting but device are unable to connect to the internet ( like unplugging the LAN cable from your ISP from the back of the router but leaving the router on ) 

2. Rebooting the smart devices does not fix the issue as they still cannot connect to the network

3. Rebooting the router sometimes works, sometimes it does not

4.  I use a Fiber-optic connection and the router is connected to another router provided by the ISP. I am not sure if this could cause the problem as the 5G connection and the LAN works perfectly fine but thought I should mention

 

 So after searching the forums and trying various fixes here's what I have tried until now:

 

1. Rebooting the Router 

2. Backup & factory resetting the router 

3. Using a WiFi analyzer and setting the channels to the clear ones, also setting the transmitting power to max and channel bandwidth to max. (This did not work so I have reverted to AUTO ) 

4. Upgrading my firmware to a beta version 1.3.6 Build 20200819 rel.50735(4555)

5. Disabled Smart connect 

 

Do you guys have any idea if this is related to the firmware version or is a hardware version? Also if it is firmware version do you have a previous build (2020) I could restore to as I am unable to find a list with previous firmware versions on TPLink's website 

 

Also do you have any more tips I could try as I am working from home and my work Optiplex is using the 2.4 Connection so getting disconnected every few hours is becoming extremely infuriating and it is compromising my work.

 

PS: I have the EU V2. hardware version 

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer C6 losing internet connection-Solution
2022-01-30 15:21:13 - last edited 2022-02-08 09:11:11

Hi @Kevin_Z

Thank you for your quick response.

My ISP claiming there was no issue on my line, another technician who was at my flat was finding a faulty Ethernet port on the cable modem.

So the issue was on the ISPs side, I got a replacement unit and since 28 hours I'm online without a single lost ping or disconnect.

I did not upgrade to the beta firmware (yet) to be sure that the problem was the modems eth0 port for about another week, logging ping on a raspberry pi 24h/day.

 

Kind regards.

Recommended Solution
  3  
  3  
#11
Options
11 Reply
Re:Archer C6 losing internet connection
2021-02-09 16:07:17 - last edited 2021-02-09 16:16:50

@Viision96 

 

If your FW version is an EU, here's the list of FW releases.

Have you tried the beta FW from this thread ? (it's in the Recommend Solution post by Kevin_Z)

You can revert from beta to the one on top of the list for sure.

When changing the FW version it's advisable to hard reset (Method 1) the device and reconfigure from scratch.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Archer C6 losing internet connection
2021-02-10 19:49:22

@Ivaylo I have tried the previously released version Archer C6(EU)_V2_20090 as well as the beta version For Archer C6EU V2: https://static.tp-link.com/2020/202010/20201030/ArcherC6v2_eu-up-ver1-3-6-P1[20201030-rel60104].zip and have experienced much fewer network crashes but they do still happen. 

Also, I have performed a factory reset after installing each version.

 

Is it safe to consider that at this point this might be a hardware issue? 

  0  
  0  
#3
Options
Re:Archer C6 losing internet connection
2021-02-10 20:13:37
In your first post you mentioned that the issue has started after a FW upgrade. So I can't say definitely that's a HW issue.
If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:Archer C6 losing internet connection
2021-03-22 01:37:19
I know it's has been a while but the problem still persists, although now I can easily fix it by rebooting the router. For some reason, all devices connected to the 2.4G connection lose internet connection and cannot reconnect automatically or manually unless I reboot the router.
  0  
  0  
#5
Options
Re:Archer C6 losing internet connection
2021-03-22 02:15:57

@Viision96 

 

When the smart devices lose the 2.4G connection, and they failed to reconnect, what is the error message? Can they still find the 2.4G network in the Wi-Fi list?

 

May I know the detailed Wireless Security setting on the C6? You may cover the SSID and password for any security concerns.

 

How many devices are connected to C6 2.4G network? What are they?

 

How often does this disconnect issue happen?

  0  
  0  
#6
Options
Re:Archer C6 losing internet connection
2021-03-22 02:30:37 - last edited 2021-03-22 02:36:23

@Kevin_Z 

 

Hello, 

The 2.4G network is visible and my devices usually give the " Unable to connect to the network" error. Once my iPhone was unable to connect and the error mentioned to check the DHCP setting but I cannot recall the exact error message. 

 

 I have two light strips, two light bulbs, and two Echo Dots also some smart panels from Nanoleaf. So that comes to about 10-12 devices.

 

Edit: The devices disconnect at least once every 24 Hrs but it's pretty random. They do remain connected for some time after rebooting but not more than 6-8 hours

 

Here are some snips:

  0  
  0  
#7
Options
Re:Archer C6 losing internet connection
2021-03-22 07:14:54

@Viision96 

 

We have reported the issue to the support engineers, they will likely reach out to you via email to continue to troubleshoot your issue.

  0  
  0  
#8
Options
Re:Archer C6 losing internet connection
2022-01-27 22:49:50

@Kevin_Z

Losing WAN connection regularily (5-20x a day I run into it, I suppose it happens more often).

When connected to ISP modem directly no disconnects happen.

 

Hardware: Archer C6(EU) v2.0
Firmware Version: Latest official: 1.3.6 Build 20200902 rel.65591(4555)

 

My PC is connected via ethernet cable, as well as a HP printer and two Raspberry Pi's.
One TP-Link Tapo C100, an iPhone, an iPad and two Sonos Wireless Speakers are connected via 2.4 GHz and 5 GHz Wifi.
No Guest-Wifi, no QoS, no Parental Controls, SPI firewall active (default setting), NAT forwarding: 4 virtual server rules active, OpenVPN VPN-Server active

 

I already did a factory reset, nothing changed.

 

I see that for the US-Version of the router there is an update available (Archer C6(US)_V2_210226 - https://www.tp-link.com/us/support/download/archer-c6/#Firmware ) that has a description like "Fixed the bug that unstable WAN connection under certain circumstances".

Can you please, please, also fix that issue for the EU-version?

 

This is becoming very annoying for me and happening more and more often.

Attached you will find a ping result file. I "masked" my IP-Addresses for security reasons.
You will still see the behaviour.

Also attached you find a screenshot of my router's webpage when the error occurs.

 

I ran a second computer straight from the ISP modem from its second eth-port. There I had _no_ lost connection over the whole time period when I was monitoring on this second computer.

 

In the near future I want to expand with a RE300 mesh-repeater that was recommended to my by your support. I already bought it. So deactivating mesh is no solution to me (in case this is the issue). Since the US-Version has an update it should also be possible for the EU-Version, right?

 

I don't want to put OpenWRT firmware on it and also not throw it in the bin, since I like the router very much as it is except this bug.

Thank you for your help.

 

File:
tp-link_archer_c6_v2_eu_wan_problem_ping_log.txtDownload
  0  
  0  
#9
Options
Re:Archer C6 losing internet connection
2022-01-29 11:11:52

Hello @lordhenry, I think the issue you are reporting has been discussed via email, please confirm if it helps.

  1  
  1  
#10
Options
Re:Archer C6 losing internet connection-Solution
2022-01-30 15:21:13 - last edited 2022-02-08 09:11:11

Hi @Kevin_Z

Thank you for your quick response.

My ISP claiming there was no issue on my line, another technician who was at my flat was finding a faulty Ethernet port on the cable modem.

So the issue was on the ISPs side, I got a replacement unit and since 28 hours I'm online without a single lost ping or disconnect.

I did not upgrade to the beta firmware (yet) to be sure that the problem was the modems eth0 port for about another week, logging ping on a raspberry pi 24h/day.

 

Kind regards.

Recommended Solution
  3  
  3  
#11
Options

Information

Helpful: 0

Views: 1595

Replies: 11

Related Articles