[Solution] Main Deco staying solid red after rebooting when working with Zmodo devices

[Solution] Main Deco staying solid red after rebooting when working with Zmodo devices
[Solution] Main Deco staying solid red after rebooting when working with Zmodo devices
2021-07-09 10:00:12 - last edited 16 hours ago
Model: Deco
Hardware Version:
Firmware Version:

This Article Applies to:

All Deco models


Issue Description/Phenomenon:

In very rare cases, customer may find that the main Deco stays solid red after a power outage or firmware upgrade, or a simple reboot of the main Deco, the client devices in the Deco network won't be able to access the internet, despite the fact that the modem’s Internet was already back.


This issue occurs and ONLY occurs when the network meets 2 conditions:

1. Main Deco works in Router mode

2. The network onnection type is “Dynamic IP


And here is a typical network topology for the situation:



When debugging with the customer, we found out the IPv4 address on Deco has been changed to a new range when the issue happens. For example, it was a public IP assigned by ISP before, but it changes to Based on the ARP checking, the gateway is the IP address of the Zmodo NVR.

Upon further checking, when the Smart DHCP device (like Zmodo NVR) loses internet, and it discovers that no DHCP Server is available in the network, because the main Deco is not up yet, it will turn on its own DHCP Server, starting to assign IP address all over the local network. In this case, the main Deco turns red, as port 2 doesn’t have internet.


The behavior of this Zmodo device is actually called “DHCP spoofing”, which will possibly bring the whole local network down. Moreover, when the Zmodo device was assigning IP addresses to other devices, the “lease time” option was set to 7 DAYS, whatever device got this kind of IP address, it will have to use this IP address at least for 7 days (unless you manually disconnect the Ethernet cable or Wi-Fi).


Available Solutions:

Actually, not only Zmodo NVR devices have a mechanism of Smart DHCP, which we also have an article about, but most Access Points or Range Extenders have this feature, so if you happened to have the same issue, please leave the model of the device in the comment below.


Here are two possible solutions for your reference:

1. Contact the Smart DHCP device manufacturer and request for disabling the Smart DHCP feature.

2. After a power outage, unplug the cable from port 2 first, only allowing the main Deco to connect through port 1, connect the cable of port 2 after the main Deco turns green.