Extender RE450 no 2.4GHz and unstable 5GHz

Extender RE450 no 2.4GHz and unstable 5GHz
Extender RE450 no 2.4GHz and unstable 5GHz
2021-07-16 20:58:04
Model: RE450
Hardware Version: V3
Firmware Version: 1.0.1 Build 20190124 Rel. 56886

Hi TP-Link Support Team, 

 

I have a RE450 Range Extender (my 2nd one) 

 

Both of the RE450 have worked for 2 Months ONLY and then it started doing the same thing again. 

 

Cannot connect to 2.4GHz and 5GHz is very unstale. 

 

Hardware Version: RE450 v3.0 

Firmware Version: 1.0.1 Build 20190124 Rel. 56886 

 

On both my laptops, 2.4GHz just cannot connect at all. 

5GHz can connect but it will disconnet after 10 mins. 

 

I had 2 RE450 and they are doing the same thing after 2 months. 

It was working perfectly without any issues for 2 months. 

First one gave problems so I return it and got the new one. 

And now it is doing the same thing again. 

 

Please assisit. 

 

Thanks 

 

 

Tony 

 

 

0
0
#1
Options
2 Reply
Re:Extender RE450 no 2.4GHz and unstable 5GHz
2021-07-17 07:29:22

Any updates ? 

 

Because I am work from home, this is really getting annoying. 

 

If there is no solution that means I need to get another extender. 

0
0
#2
Options
Re:Extender RE450 no 2.4GHz and unstable 5GHz
2021-07-19 03:33:47

@Tony_Keung  Hello, 

 

Please check the back label of your RE, is it (EU) or (UK) version. 

If you have (EU) version range extender, please update below firmware and see it help with the issue? 

https://www.tp-link.com/en/support/download/re450/v3/#Firmware

 

May I know how about the 2* WIFi led on RE450 when issue occurs and do you have a stable 2.4G/5Ghz network from router at RE's location? 

0
0
#3
Options