Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers
Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers
2023-04-17 15:32:02
Model: Archer C2300  
Hardware Version: V1
Firmware Version: tried all of them

After few days of troubleshooting and researching and reading this forum as well, it seems my c2300 v1 (EU version) has the infamous QoS bug where I can't fully disable the QoS (even when on standard settings) and it randomly decides to cut my gigabit speed in half. Only restart fixes the router and the speed, I tried playing with all settings, wasted few days of my time, nothing works. 
So it seems Tp-link doesn't want to solve this issue and just let its users to suffer or buy a new router. On top of it I don't have the option of flashing with openwrt or some other open source firmware because of the broadcom cpu. 

I'm kindly asking the support here, is it possible to provide me with some link for C2300 v1 (EU) very first firmware, the one it was released it? It seems it didn't have QoS back then, the QoS was added with firmware 2.0.1 Build 20171121 Rel. 61622 . I tried 4 different firmwares, same issue persists, but I can't find the firmware that my router shipped with, the very very first one. Please guys, if you have any chance of locating this I would be very grateful to try it, since it will solve the QoS issue. It's probably just the version before
/2.0.1 Build 20171121 Rel. 61622/

Thank you in advance.

  0      
  0      
#1
Options
2 Reply
Re:Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers
2023-04-21 02:16:34

@gen66 

 

Hi, as suggested by terziyski in the following thread, you can try resetting the C2300 to factory defaults, which will disable QoS automatically:

https://community.tp-link.com/en/home/forum/topic/606404

If my reply helps with the issue, please click on the arrow pointing upward. If it solves your issue, please click the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Router C2300 v1(EU), buggy QoS cuts my speed in half, the infamous bug of many Tp-link routers
2023-04-21 11:42:43

  @Liverpool20 Thank you for the reply. I tried this already, few time completely reset it to factory default by holding the reset button. After some time the QoS still works and limits the speed. I guess c2300 version 1 is just bugged beyond repair with its current firmware, unless there is a new firmware version it's useless. Thank you Tp-Link for looking after your clients who spend money. I guess buying a router in 2018 I'm not worth of proper fixes for your defective products.

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 336

Replies: 2