Deco XE75 stuck restarting (yellow light to red light to yellow light)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Deco XE75 stuck restarting (yellow light to red light to yellow light)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco XE75 stuck restarting (yellow light to red light to yellow light)
Deco XE75 stuck restarting (yellow light to red light to yellow light)
2023-08-27 23:18:20 - last edited 2023-08-29 02:14:00
Model: Deco XE75  
Hardware Version: V1
Firmware Version: unknown

I am not sure which hardware version or firmware version I am using.

 

Today, the main router stopped working (I am on a 2 pack system).

 

I have restarted the cable modem and main router (the one connected to the cable modem).

 

The main router's light stays yellow a while then changes to red then back to yellow.

 

I have tried resetting the main router for 1 sec (and longer) when the main router is unplugged from power and when plugged from power to try to rollback the firmware version. However, I am getting the same yellow light/red light/yellow light pattern.

 

Please help.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Deco XE75 stuck restarting (yellow light to red light to yellow light)-Solution
2023-08-28 13:59:30 - last edited 2023-08-29 02:14:00
Hello, I followed your instructions to reset my main router and that worked! Of course, I had to re-add the devices to my network using the TP-Link app and all is working fine now. I did not check the other power adapter since the reset worked. Thank you so much for your help!
Recommended Solution
  1  
  1  
#5
Options
4 Reply
Re:Deco XE75 stuck restarting (yellow light to red light to yellow light)
2023-08-28 01:57:37

  @TJ64 

Hi, Have you tried to power it off for about 10-15mins, then hold the reset pinhole for 1s and wait for a little longer, maybe 2-3mins? After that, would it turn to flashing blue?

If still nothing changed, I am afraid that you might need to contact technical support for warranty service:

https://www.tp-link.com/support/contact-technical-support/#Warranty-Support

Thank you very much and best regards.

 

 

  0  
  0  
#2
Options
Re:Deco XE75 stuck restarting (yellow light to red light to yellow light)
2023-08-28 02:06:54
Thank you for your reply. Just to clarify, do I press the pinhole reset while the router is powered on or while it is powered off? If powered on, do I press the reset immediately after powering on or do I wait a while? Thanks!
  0  
  0  
#3
Options
Re:Deco XE75 stuck restarting (yellow light to red light to yellow light)
2023-08-28 11:48:56 - last edited 2023-08-28 11:51:20

  @TJ64 

Hi, for factory reset, we just need to hold the reset pinhole for 1s when it is powered on. It would be better to wait a while to make sure it fully started.

 

By the way, I saw a similar post here and have you tried to swap the power adapter between two Deco XE75 to see whether a new adapter made any difference?

https://community.tp-link.com/en/home/forum/topic/620390

Wait for your reply and best regards.

 

  0  
  0  
#4
Options
Re:Deco XE75 stuck restarting (yellow light to red light to yellow light)-Solution
2023-08-28 13:59:30 - last edited 2023-08-29 02:14:00
Hello, I followed your instructions to reset my main router and that worked! Of course, I had to re-add the devices to my network using the TP-Link app and all is working fine now. I did not check the other power adapter since the reset worked. Thank you so much for your help!
Recommended Solution
  1  
  1  
#5
Options

Information

Helpful: 0

Views: 932

Replies: 4

Related Articles