Bluetooth UB500 don´t work with microphone.

Bluetooth UB500 don´t work with microphone.

Bluetooth UB500 don´t work with microphone.
Bluetooth UB500 don´t work with microphone.
2024-02-27 16:57:24
Model: UB500  
Hardware Version: V1
Firmware Version:

Hi. My desktop PC has Windows 11 23H2. I want to use my earphones (Earfun Air and Skullcandy Evo), but only the microphone does not work. The earphones sound great, but for example I can't make a video call because the microphone doesn't work. Windows recognizes the microphone in the <sound settings>, but it does not work. I installed the UB500 driver; I already updated the sound drivers, uninstalled them, updated them again and nothing. I repaired Windows 11 with Windows tech support and nothing. The same thing happens with the UB400 adapter, I remember that in Windows 10 I didn't have that problem. Even the OBS recognizes the microphone, but does not capture the sound.

 

Please, I need help.

 

Thanks!

 

  0      
  0      
#1
Options
2 Reply
Re:Bluetooth UB500 don´t work with microphone.
2024-02-29 01:13:00

  @xtiann 

Hi, Have you connected to another earphone or headset to test whether UB500 could capture the sound?

 

  0  
  0  
#2
Options
Re:Bluetooth UB500 don´t work with microphone.
3 weeks ago - last edited 3 weeks ago

  @xtiann 

 

Hi,

After alot of time spent on this, I finally figure it out.
It looks like Phone Link was using a different sound device, even that was disabled both in Device Manager and in Sound Settings. In my case it was a Logitech C270 HD WebCam that I keep disabled 99% and only enable it in case of having an interview.

Just finished installing Windows 11, so ALL is fresh.

Even tough in Sound Settings the only Michrophone enabled and set as default for both Device and Default Communication and was my FiFine F4, it seems that Phone Link was still hardcoded to use my disabled wecam. I guess bad coding that hardcodes the first device discovered by Phone Link and never releases it.

In a moment of ..... trying and trying, in order to see if my microphone was not "supported", I have enabled the WebCam, and instantly I could hear the mic in my phone.

In order to force Phone Link to use my actual FiFine F4 Microphone, I have physically disconnected the WebCam, and deleted all other audio input devices from "Audio inputs and outputs", and from "Sound, video and game controllers". After that, I've rebooted, tested Phone Link, working, and then reconnected the WebCam again.

Hope this works for you!

  0  
  0  
#3
Options