Problem connecting to PPPoe

Problem connecting to PPPoe
Problem connecting to PPPoe
2014-02-01 23:06:00
Region : India

Model : TD-W8968

Hardware Version : V1

Firmware Version : 0.6.0 1.3 v0005.0 Build 131226 Rel.33881n


Hello. I am having problem connecting to the PPPoe using the EWAN port. I'm facing this problem since a few days ago, before which it was perfectly fine. I'm not connected to any modem, but the Cat-5 cable from the ISP goes directly into the router's EWAN. I'm using the router in ' Wireless mode'. This problem persists even after upgrading to the latest firmware and persisted before upgrading also.

The problem is as follows.
Whenever I press the ' connect' button on the ' WAN Settings' page, the router goes into a ' connecting...' loop. OR It displays ' Connecting...' for 3 secs and reverts back to ' Connect'. In both the cases nothing is written into the Debug log. This problem sometimes gets solved after 2-3 router reboots. If not, I try the below method. Also whenever I disconnect and try to reconnect again, the problem reappears and gets solved only by constant reboots.

Sometimes I switch to the ' Always on' method and the router successfully connects to the Internet.

I always ensure that my ISP servers are up and the Internet is not down either by connecting to the Internet via my PC or by connecting the cable to my LAN port and dialing to PPPoe from the PC. Which also ensures that my cable is not damaged either.

Please provide me a possible working solution :(