bridge with AP not working (cannot get IP)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
bridge with AP not working (cannot get IP)
bridge with AP not working (cannot get IP)
2014-09-07 12:44:36
Region : Argentina

Model : TL-WA801ND

Hardware Version : V3

Firmware Version : 3.15.9 Build 140425 Rel.44079n

ISP :


Sorry for my bad english.

I have a DLINK DIR-600 as main modem/router/AP conneted to cable internet. Let's call it A (192.168.0.1).

To improve coberture, I bought a WA801ND, let's call it B (192.168.0.254).

Both are at two different spaces and for different people, so I do need two different SSIDs & passwords, so I have to put B on "bridge with AP mode".
I have done this before, with this same device, and it worked ok (I can't remember brand nor model of the AP).

Well. I connect B to A by wlan.
If I put B in "client" mode, with a PC connected to B by wire, it works like a charm. No issues.
If I put B in "universal repeater" mode, it works kike a charm. No issues. Very strong signal. I can connetc any wifi device to B (from a place I know A can't reach) and navigate with no issues.
But when I put B in "bridge with AP" mode, I can't make it work at all. Let's see.
B is always wirelessly connected to A. I can ping each other.
But the PC connected to B by wire cannot navigate anymore, nor ping A.

If I disable DHCP in B, any device trying to connect to B by wifi, can't get an IP, and no connection.
If I enable DHCP, the device gets a IP from B, but it's not recognized by A: I can't ping A, and the device's not listed in A's clients list. Of ocurse, the device can't navigate at all.

But in any case, any device connected to A can ping B, and even access B's setup page.

I've tried with static/dynamic IP for B; changing the gateway to A's IP; using same/different password; messing with DNSs, channels, etc etc and no luck.

Any ideas? Thank you very much.
0
0
#1
Options
1 Reply
Re:bridge with AP not working (cannot get IP)
2014-09-09 18:52:48
reboot the Dlink, ensure there is no IP reservations or ARP banding on the Dlink
reset the WA801, reconfigure bridge with AP mode. Disable DHCP.
0
0
#2
Options