C200 stopped seeing SD card

C200 stopped seeing SD card
C200 stopped seeing SD card
2020-04-22 11:33:13 - last edited 2020-04-23 09:11:47
Model: Tapo C200
Hardware Version: V1
Firmware Version: 1.0.7

Tapo C200 - Hardware version: 1.0  Firmware  version: 1.0.7    SD Card: ScanDisk Ultra 32GB & 128GB (Both FAT32)


I've had this camera for 2 weeks and it has been working fine.
All aspects did as they should.
Then yesterday, while I was near the camera a voice said something like "There's a problem reading the SD card".
After this I noticed that I couldn't see any playbacks from motion detected incidents!

I took the card from the camera and tried it in my computer & it seemed to be about 98% full.

Thinking this was the issue I deleted the unwanted files and put the card back in the camera.

This didn't cure the problem so I tried another card, which is the same.

The camera isn't recognising the SD cards for some reason.

It just says "No microSD card" and I can't enable microSD Recording either.

Any help would be appriciated.


2 Replies
Re:C200 stopped seeing SD card
2020-04-26 08:37:13


What's your app version? Please make sure it is up-to-date. Then you may refer to the suggestion below to do some troubleshooting.


Turn off the camera, remove and re-insert the SD card several times. Then turn on the camera and check if the SD card could be recognized.

If the SD card could be recognized by the computer, please try to format it to FAT32 on the computer. After that, insert the SD card into the camera again for a check.


It’s also suggested to test the card with third-party software such as MyDiskTest and here is more suggestion to verify an SD card.

Re:C200 stopped seeing SD card
2020-04-30 10:38:55


My App version is 2.2.7, the latest at this point in time. (April 2020)


I have done the turn it off and on again test, countless times, without success. Also remove and re-insert it. Still not being recognised though.


As mentioned in my original post the card has been checked and formatted to FAT32 and still not recognised by the camera.


I did as you suggested and followed your link, I downloaded the disk checker and let it do it's thing.

The disk shows no errors and is proved not to be a fake too.


Still not recognised by the camera, which suggests to me that it is in fact the camera that is faulty, not either of the brand new Scandisk SD cards.


As originally stated, the SD card worked fine for a while until the camera decided to not recognise it!


How do I go about getting a refund plaese?

Related Articles