TAPO C100: Unable to access RTSP stream

TAPO C100: Unable to access RTSP stream
TAPO C100: Unable to access RTSP stream
2020-09-23 10:42:25
Model: Tapo C100
Hardware Version: V1
Firmware Version: 1.0.10

I am unable to view the RTSP stream from either of two recently purchased C100 cameras (firmware 1.0.10). Both cameras show in the Tapo app & I have followed the guide at https://www.tp-link.com/us/support/faq/2680/.

 

Username / Passwords have been set in the Advanced Settings / Camera Account section.

 

I am using a TP-Link Archer VR2800 router with DHCP & the cameras have been allocated IP's 10.50.10.106 & 10.50.10.111.

 

Using the format rtsp://username:password@10.50.10.111:554/stream2 in VLC from a computer on the same network gives the error "connection failed".

 

I have also tried scanning / adding the camera via "IP Cam Viewer" on an Android phone, but no stream is found (so it appears not to be an authentication issue).

 

Neither camera responds to a ping on its IP, but I don't know if this is normal.

 

Any ideas?

0
0
#1
Options
5 Replies
Re:TAPO C100: Unable to access RTSP stream
2020-09-23 15:35:57

A further update... If I do an NMAP scan of the camera IP it's not showing any ports open at all.

 

Has anyone managed to get an RTSP stream from a C100 with the 1.0.10 firmware?

0
0
#2
Options
Re:TAPO C100: Unable to access RTSP stream
2020-09-24 11:44:10

@CT800 

Good day.

Do you want to live view the camera locally or remotely?

---If remotely, Have you opened port 554 for the Tapo C100 on the VR2800?

---And could you please also check the internet IP address on VR2800 a public IP address, not a private one?

Have you checked if you could live view the camera locally when the computer is located behind the VR2800?

And Are you able to ping 10.50.10.106/111 on this computer?

 

Thank you very much.

0
0
#3
Options
Re:TAPO C100: Unable to access RTSP stream
2020-09-25 08:12:25

@Brook  Hi, thank you for your reply.

I am just trying to view the RTSP stream locally, so there are no firewall issues. 

A ping of 10.50.10.106/111 gives the result "Ping request could not find host 10.50.10.106/111. Please check the name and try again."

As mentioned in the earlier post, I am not able to ping the camera at all & scans show no ports open. This is the same for both new cameras.

 

0
0
#4
Options
Re:TAPO C100: Unable to access RTSP stream
2020-09-26 10:14:47

@Brook

 

OK, this is even more strange. I plugged both cameras back in today. I haven't changed anything on the router and the only thing I can think is different is that I'd removed the micro SD cards from the cameras (Kingston Endurance 32GB Class 10). I can now ping both cameras and I'm able to stream from RTSP port 443.

 

Having scanned both cameras with NMAP, both cameras show open ports on 443, 554, 8800 & 2020. Strangely, one of the cameras also has port 20002 open. I'm not sure why this is only on one camera...?

 

I've put the SD cards back in the cameras & the ports have remained open. I'm not sure why the ports weren't opened initially? The Firmware version still shows 1.0.10. The build version is 200519 Rel 66820n(455), but I didn't take a note of this before.

0
0
#5
Options
Re:TAPO C100: Unable to access RTSP stream
2021-02-23 21:41:03

Im having the same issues rtsp feed comes and goes. Ping is the same when I get a feed ut also replyes to ping. I leave vlc on, and eventually it will connect but its annoying to deal with. Anyone with same issues? 

 

0
0
#6
Options